The online community for software testing & quality assurance professionals
 
 
Calendar   Today's Topics
Sponsors:




Lost Password?

Home
BetaSoft
Blogs
Jobs
Training
News
Links
Downloads



Testing Tools >> HP Functional Testing / Mercury QuickTest Pro / QTP

Davowulf
Advanced Member


Reged: 07/31/03
Posts: 512
Loc: Sudbury MA
Re: Lost with web app that uses ajax Infragistics
      10/27/10 08:17 AM

Thank you so much!

Check boxes look like they can be identified pretty easily, it doesn't look like Infragistics factors into it. Or to be more accurate, my AUT changed so it doesn't do it that way anymore. Instead of checking off the values, you can select them in an infragistics grid.

Do you populate cells in the Infragistics table? QTP sees them as webtables.

I've done GetCellData against that cell, and it returns what is there. So reading the cells seems ok.

I've tried WebList and WebEdit (I have have both in the same line)

Every time I get an "object required" error on the "set" line of code. Why doesnt this work?

Set WebEditObj = Browser("Browser").Page("ItemLines").Frame("body").WebTable("Line").ChildItem(2, 5, "WebEdit", 0)

WebEditObj.Set "3"

Thanks again for getting back to me, at least I know there's someone else in the world using this. Does your app use AJAX as well?

Edited by Davowulf (10/27/10 09:53 AM)

Post Extras Print Post   Remind Me!     Notify Moderator


Entire topic
Subject Posted by Posted on
* Lost with web app that uses ajax Infragistics Davowulf 05/11/10 08:08 AM
. * * Re: Lost with web app that uses ajax Infragistics Davowulf   05/13/10 06:45 AM
. * * Re: Lost with web app that uses ajax Infragistics Jene   05/13/10 08:44 AM
. * * Re: Lost with web app that uses ajax Infragistics Tarun LalwaniModerator   05/15/10 11:11 AM
. * * Re: Lost with web app that uses ajax Infragistics Davowulf   05/21/10 07:55 AM
. * * Re: Lost with web app that uses ajax Infragistics QA_Auto_Tester   05/21/10 08:29 AM
. * * Re: Lost with web app that uses ajax Infragistics Davowulf   10/26/10 06:55 AM
. * * Re: Lost with web app that uses ajax Infragistics Davowulf   10/26/10 07:17 AM
. * * Re: Lost with web app that uses ajax Infragistics MLee   10/27/10 04:18 AM
. * * Re: Lost with web app that uses ajax Infragistics Davowulf   10/27/10 08:17 AM
. * * Re: Lost with web app that uses ajax Infragistics MLee   10/28/10 11:25 PM
. * * Re: Lost with web app that uses ajax Infragistics umeshvm   05/19/10 05:01 AM

Extra information
0 registered and 109 anonymous users are browsing this forum.

Moderator:  IanFraser, Rajkumar_Rajangam, thorwath, TReddy, AJ, Tarun Lalwani, mwsrosso 



Forum Permissions
      You cannot start new topics
      You cannot reply to topics
      HTML is disabled
      UBBCode is enabled

Rating:
Thread views: 2450

Rate this thread

Jump to

Contact Us | Privacy statement SQAForums

Powered by UBB.threads™ 6.5.5