The online community for software testing & quality assurance professionals
 
 
Calendar   Today's Topics
Sponsors:




Lost Password?

Home
BetaSoft
Blogs
Jobs
Training
News
Links
Downloads



Testing Tools >> HP / Mercury LoadRunner

Pages: 1
kanwalpreet7
Newbie


Reged: 03/11/07
Posts: 20
Recording issues for Siebel 8.1 with Loadrunner 11
      #702267 - 03/22/12 12:56 PM

Hi,

We have not been able to record Siebel 8.1 application through Loadrunner 11.0. During recording, after entering username and password, the IE browser in which the Siebel application is opened gets locked and load runner does not record anything. At this step, Siebel opens up three new windows (pop-ups) if we do it manually. We have tried changing all the IE settings that are required to get it to work, but it did not work.
We also did made sure that Loadrunner 11.0 can record Siebel 7 application.
We have opened a case with HP and they came back with the answer that Loadrunner 11.0 do not support Siebel 8.1 application.

Does anyone know if there is any solution to this or there is any other tool which can be used to loadtest Siebel 8.1?

Thanks,
Kanwalpreet


Post Extras: Print Post   Remind Me!   Notify Moderator  
JimHowell1970Moderator
Active Member


Reged: 02/18/10
Posts: 836
Loc: Europe
Re: Recording issues for Siebel 8.1 with Loadrunner 11 [Re: kanwalpreet7]
      #702428 - 03/23/12 12:41 PM

there are always ways and means

what protocols have you tried?

have you tried either fiddler or a tcp dump to extract the raw http calls from?


Post Extras: Print Post   Remind Me!   Notify Moderator  
kanwalpreet7
Newbie


Reged: 03/11/07
Posts: 20
Re: Recording issues for Siebel 8.1 with Loadrunner 11 [Re: JimHowell1970]
      #702439 - 03/23/12 04:20 PM

Thanks a lot for your reply. We have tried both Siebel Web and Web(http/html) protocol. What is wierd is that we can record Siebel 7.0 application, however Siebel 8.1 does not work. We have Loadrunner 11.0 and we are on Windows 2003 server.

I have tried all possible options, copied ssdtcorr.dll file in the bin folder of Loadrunner. Changed settings on the Siebel server side as well (Enable Automation=True, EnableWebClientAutomation = TRUE). Nothing works. When the loadrunner hangs, I checked Generation log, and I see below errors:

Event Matching error: IN event left without an OUT event at end of recording.

If you can help out in any way, that would be greatly appreciated.

Regards,
Kanwalpreet


Post Extras: Print Post   Remind Me!   Notify Moderator  
kanwalpreet7
Newbie


Reged: 03/11/07
Posts: 20
Re: Recording issues for Siebel 8.1 with Loadrunner 11 [Re: kanwalpreet7]
      #702440 - 03/23/12 04:23 PM

I have tried process explorer to get the list of dll's which run during the time when I record, but I was not able to see if there is any particular process/dll which is causing the problem. Also, I am not sure what is the purpose of doing tcp dump.

Post Extras: Print Post   Remind Me!   Notify Moderator  
ptrussell_ncModerator
Super Member


Reged: 01/17/06
Posts: 1636
Loc: Charlotte, NC
Re: Recording issues for Siebel 8.1 with Loadrunner 11 [Re: kanwalpreet7]
      #702544 - 03/26/12 05:52 AM

Quote:

...
We have opened a case with HP and they came back with the answer that Loadrunner 11.0 do not support Siebel 8.1 application.

...




This means that direct recording probably will not work.

Have you tried WinSock?

And as Jim suggested you can use a sniffer to capture the traffic and then build a script by hand.

WinSock is a lot of work. Sniffer is a lot a lot of work.

--------------------
Unless you are writing a compiler, strtok is NOT the answer.
See: http://www.sqaforums.com/showflat.php?Cat=0&Number=541641&Main=541641#542222

QAF is still an exercise in self-sufficiency! (Thank JB!)


Post Extras: Print Post   Remind Me!   Notify Moderator  
James PulleyModerator
Moderator


Reged: 08/01/01
Posts: 5551
Loc: NC
Re: Recording issues for Siebel 8.1 with Loadrunner 11 [Re: ptrussell_nc]
      #702552 - 03/26/12 06:45 AM

(1) Turn off all autocorrelation rules
(2) Turn on record as URL mode (as an alternate use web_custom_requests())

See if you record anything then.


Post Extras: Print Post   Remind Me!   Notify Moderator  
kanwalpreet7
Newbie


Reged: 03/11/07
Posts: 20
Re: Recording issues for Siebel 8.1 with Loadrunner 11 [Re: James Pulley]
      #702557 - 03/26/12 07:17 AM

I have turned off all correlation rules and tries recording in url mode as well. Loadrunner did record until login. After login, 3 pop up windows are generated and within Siebel, a web page from a Java build application is displayed. At this point, IE crashes.

Post Extras: Print Post   Remind Me!   Notify Moderator  
James PulleyModerator
Moderator


Reged: 08/01/01
Posts: 5551
Loc: NC
Re: Recording issues for Siebel 8.1 with Loadrunner 11 [Re: kanwalpreet7]
      #702558 - 03/26/12 07:41 AM

What about web_custom_request?

Try a proxy mode recording in LR. alternatively, try looking ta a tool like charles proxy which could capture a trace for you which could be manually converted to a script.


Post Extras: Print Post   Remind Me!   Notify Moderator  
kanwalpreet7
Newbie


Reged: 03/11/07
Posts: 20
Re: Recording issues for Siebel 8.1 with Loadrunner 11 [Re: James Pulley]
      #702563 - 03/26/12 08:34 AM

I have tried web_custom_request as well, same result. IE crashes. I am not sure how to do proxy mode recording in LR. I tried searching it on the net and when I use old recording engine, I get an error that IE 8 does not support it.

Post Extras: Print Post   Remind Me!   Notify Moderator  
James PulleyModerator
Moderator


Reged: 08/01/01
Posts: 5551
Loc: NC
Re: Recording issues for Siebel 8.1 with Loadrunner 11 [Re: kanwalpreet7]
      #702573 - 03/26/12 10:14 AM

Quote:


I am not sure how to do proxy mode recording in LR





Time to head to the manuals.....Hint, recording options....port mapping...unix applications....


Post Extras: Print Post   Remind Me!   Notify Moderator  
JimHowell1970Moderator
Active Member


Reged: 02/18/10
Posts: 836
Loc: Europe
Re: Recording issues for Siebel 8.1 with Loadrunner 11 [Re: James Pulley]
      #702904 - 03/29/12 12:13 AM

I have a POC for a Siebel 8.1 upgrade on my books in the next week or so I believe (as soon as they give me the url and users for the test environment) so I'll report back whilst doing it

I'd suggest trying a different OS/browser as well (do you have access to anything other than what you are using - I'll be on XPSP3/IE6 initially)


Post Extras: Print Post   Remind Me!   Notify Moderator  
kanwalpreet7
Newbie


Reged: 03/11/07
Posts: 20
Re: Recording issues for Siebel 8.1 with Loadrunner 11 [Re: JimHowell1970]
      #703352 - 04/03/12 07:45 PM

We were able to get it to work by changing a registry setting which disables NTLM. Thanks for all your help.

Post Extras: Print Post   Remind Me!   Notify Moderator  
Pages: 1



Extra information
0 registered and 50 anonymous users are browsing this forum.

Moderator:  AJ, James Pulley, ptrussell_nc, JimHowell1970 

Print Topic

Forum Permissions
      You cannot start new topics
      You cannot reply to topics
      HTML is disabled
      UBBCode is enabled

Rating:
Topic views: 4715

Rate this topic

Jump to

Contact Us | Privacy statement SQAForums

Powered by UBB.threads™ 6.5.5