The online community for software testing & quality assurance professionals
 
 
Calendar   Today's Topics
Sponsors:
Lost Password?

Home
BetaSoft
Blogs
Jobs
Training
News
Links
Downloads



Testing Tools >> JMeter

Pages: 1
Venkatasubramaniyan KR
Junior Member


Reged: 10/22/02
Posts: 1
Loc: Bangalore, India
JMeter isn't producing reqd 'Current Connections'
      #696468 - 01/23/12 05:34 AM

We are testing a sharepoint 2010 (Intranet) appln using JMeter. One of the counter called 'Current Connections' using PerfMon is showing the same user load number. For e.g. if we do the load with JMeter for 10 users, you can see 10 current connections at the IIS web server.

Whereas the same test, run with VSTS show up about 2x (twice) 20 current connections at webserver using PerfMon. This is causing whether the actual load is generated at the webserver or not. Even normal IE browser shows up 2x, 3x connections at IIS webserver.

When we looked at the throughput and no. of txns generated during the load test, we could see that JMeter produces about 6-7% less than that of VSTS. What could be the reason, why this difference is seen at IIS webserver. Kindly help.


Post Extras: Print Post   Remind Me!   Notify Moderator  
Oliver_Lloyd
Member


Reged: 06/04/11
Posts: 246
Loc: London, England
Re: JMeter isn't producing reqd 'Current Connections' [Re: Venkatasubramaniyan KR]
      #696474 - 01/23/12 06:54 AM

Try examining the actual requests that are made by a browser and then looking at what you have configured for JMeter - chances are you're not comparing like for like. Play around with caching, with the options for 'Retrieving all Embedded Resources' and with Headers - all of these things will affect what is requested by the test and you need to understand what they are how they affect HTTP traffic. If you're not sure about the HTTP protocol and browser/server communication then Google is your friend.

Finally, once you have a clear understanding of how HTTP traffic flows, consider what you actually *want* JMeter to do. Do you really want to test all those jpgs? Is static content served by a CDN? What are the expiry headers set to? Is this an external or internal app? etc.

--------------------
http503.com


Post Extras: Print Post   Remind Me!   Notify Moderator  
Pages: 1



Extra information
0 registered and 1 anonymous users are browsing this forum.

Moderator:  icruiser, AJ 

Print Topic

Forum Permissions
      You cannot start new topics
      You cannot reply to topics
      HTML is disabled
      UBBCode is enabled

Rating:
Topic views: 1106

Rate this topic

Jump to

Contact Us | Privacy statement SQAForums

Powered by UBB.threads™ 6.5.5