The online community for software testing & quality assurance professionals
 
 
Calendar   Today's Topics
Sponsors:
Lost Password?

Home
BetaSoft
Blogs
Jobs
Training
News
Links
Downloads



Testing Tools >> Selenium

Pages: 1
daluu
Member


Reged: 08/24/06
Posts: 339
Firefox start issues with WebDriver Java & remote
      #692610 - 12/03/11 11:37 PM

Did I find bug, or any ideas what might be wrong with my system/config?

I'm briefly testing WebDriver off and on with various languages. Noticed the following

for Firefox:

FirefoxDriver working fine under Python binding. Not working for me under Java binding.

Firefox also not working under RemoteWebDriver mode whether using Python, Java, or some

third party PHP binding.

What happens when I get error is that Firefox browser does start up (blank), but the

code that started it already crashed due to exception. This doesn't happen with

Python's FirefoxDriver.

Error received for FirefoxDriver Java binding:

Error communicating with the remote browser. It may have died.
Build info: version: '2.14.0', revision: '14955', time: '2011-11-29 11:43:45'
System info: os.name: 'Windows XP', os.arch: 'x86', os.version: '5.1', java.version:

'1.6.0_27'
Driver info: driver.version: FirefoxDriver

I'm using Firefox 3.6.20

Error received for Firefox over RemoteWebDriver:

Connection reset; duration or timeout: 5.17 seconds
Build info: version: '2.14.0', revision: '14955', time: '2011-11-29 11:43:45'
System info: os.name: 'Windows XP', os.arch: 'x86', os.version: '5.1', java.version:

'1.6.0_27'
Driver info: driver.version: RemoteWebDriver

Also notice that webdriver.firefox.bin and other properties are null when I check them

via System.out.println("FF bin: " + System.getProperty("webdriver.firefox.bin"));

Also IE works fine under RemoteWebDriver. InternetExplorerDriver also works in Python

and Java, though with Java, I get this browser startup warning message (in stdout):

Dec 3, 2011 9:28:20 PM org.apache.http.impl.client.DefaultRequestDirector tryExecute
INFO: I/O exception (org.apache.http.NoHttpResponseException) caught when processing

request: The target server failed to respond
Dec 3, 2011 9:28:20 PM org.apache.http.impl.client.DefaultRequestDirector tryExecute
INFO: Retrying request

This is puzzling me...


Post Extras: Print Post   Remind Me!   Notify Moderator  
Pages: 1



Extra information
0 registered and 13 anonymous users are browsing this forum.

Moderator:  LNB, AJ, michaeljf 

Print Topic

Forum Permissions
      You cannot start new topics
      You cannot reply to topics
      HTML is disabled
      UBBCode is enabled

Rating:
Topic views: 1022

Rate this topic

Jump to

Contact Us | Privacy statement SQAForums

Powered by UBB.threads™ 6.5.5