The online community for software testing & quality assurance professionals
 
 
Calendar   Today's Topics
Sponsors:




Lost Password?

Home
BetaSoft
Blogs
Jobs
Training
News
Links
Downloads



Testing Tools >> OpenSTA

Pages: 1
Paresh Wankhede
Junior Member


Reged: 02/16/05
Posts: 7
Loc: Pune
Basic OpenSTA Tutorial
      #295204 - 02/17/05 01:19 AM

Hello friends,
I am new to this group, & also very new to the OpenSTA.
Can anybody tell me the exact procedure to configure this tool,b'coz every time i go for record script, each time it captures the same script.I am testing our struts based web application.
As mentioned in the "Which Us President?" demo web site testing, some new script should get captured every time i run my application....

Thanks & regards,
Paresh Wankhede


Post Extras: Print Post   Remind Me!   Notify Moderator  
jimitg
Junior Member


Reged: 02/07/05
Posts: 6
Loc: hyderabad
Re: Basic OpenSTA Tutorial
      #295205 - 02/17/05 03:53 AM

Steps-
After recording a script
Go to Commander
Create a New Test
Drag and drop the script in Task column
Check the "Task Group" which you want to run and provide parameters like VU, Delay etc as per your project need.
Compile script and Execute

;-) NJoy!!
Jimit


Post Extras: Print Post   Remind Me!   Notify Moderator  
srsqa
Junior Member


Reged: 02/18/05
Posts: 2
Loc: Room No8, Shevanti Lodge, Sada...
Re: Basic OpenSTA Tutorial
      #295206 - 02/18/05 11:03 PM

Dear Jimit

The Steps you have proved is qyite clear and as well as confusing one just after Create a New Test step how to Drag and Drop the script in Task Column and what is task group. Please help me in this I need to work on this and to submit report to my PM


Regards
Praveen Kumar Pandey


Post Extras: Print Post   Remind Me!   Notify Moderator  
Rajat Satender..
Member


Reged: 10/05/03
Posts: 97
Loc: Noida
Re: Basic OpenSTA Tutorial
      #295207 - 02/20/05 08:32 PM

First you need to create a test scenario under tests folder. Once the script is ready drag your script into the task1 column within the test scenario just created. Then set the scenario settings as suggested. A task group can contain more than one script which will get executed collectively as per the scheduling of the task group.

-Rajat


Post Extras: Print Post   Remind Me!   Notify Moderator  
Paresh Wankhede
Junior Member


Reged: 02/16/05
Posts: 7
Loc: Pune
Re: Basic OpenSTA Tutorial
      #295208 - 02/20/05 11:04 PM

hi all...
but when i click on record script button... it records same script for all web pages... Am i missing any setting? bcoz the tutorial discuss on the grounds of the script collected.. pls help me out...


Post Extras: Print Post   Remind Me!   Notify Moderator  
Rajat Satender..
Member


Reged: 10/05/03
Posts: 97
Loc: Noida
Re: Basic OpenSTA Tutorial
      #295209 - 02/21/05 02:40 AM

Try cleaning up the cache and cookies before recording.

-Rajat


Post Extras: Print Post   Remind Me!   Notify Moderator  
Paresh Wankhede
Junior Member


Reged: 02/16/05
Posts: 7
Loc: Pune
Re: Basic OpenSTA Tutorial
      #295210 - 02/22/05 12:53 AM

hey guys, I found the solution why the script is not getting recorded.
-- Do the setting for ur proxy in the browser's connection setting considering that ur machine will serve as proxy now. i.e. give the ip address of ur machine. Then it works....
-- now another problem is when u configure the gateway selecting local option, the proxy field is readony & it should show empty address & empty port no.What is happening is in address field my machine name is appearing & it is showing port no that i gave in browser setting.
Bcoz of this, the script is not getting captured now... Have anyone encountered with such situation ?

Thanks & regards,
Paresh


Post Extras: Print Post   Remind Me!   Notify Moderator  
Paresh Wankhede
Junior Member


Reged: 02/16/05
Posts: 7
Loc: Pune
Re: Basic OpenSTA Tutorial
      #295211 - 02/25/05 08:53 PM

Any body knows whow to use collector ?
... paresh


Post Extras: Print Post   Remind Me!   Notify Moderator  
Rajat Satender..
Member


Reged: 10/05/03
Posts: 97
Loc: Noida
Re: Basic OpenSTA Tutorial
      #295212 - 02/28/05 02:55 AM

Go to File > New Collector > NT Performance

1.Give a name to the new Collector.

2.Double-click the new NT Performance Collector icon in the Repository Window to open it in the Collector Pane.

3.This is the workspace where you can develop a Collector by defining your data collection queries.

-Rajat


Post Extras: Print Post   Remind Me!   Notify Moderator  
Paresh Wankhede
Junior Member


Reged: 02/16/05
Posts: 7
Loc: Pune
Re: Basic OpenSTA Tutorial
      #295213 - 03/01/05 08:40 PM

can tests be arranged such that when first test finishes then & then only second test starts...

... paresh


Post Extras: Print Post   Remind Me!   Notify Moderator  
Rajat Satender..
Member


Reged: 10/05/03
Posts: 97
Loc: Noida
Re: Basic OpenSTA Tutorial
      #295214 - 03/02/05 01:50 AM

Place the 2 scripts under task1 and task2 columns under the same test groups. The script under task2 will run only when the task1 script is complete.

If you have to run them concurrently then make separate task groups for both the scripts.

-Rajat


Post Extras: Print Post   Remind Me!   Notify Moderator  
Paresh Wankhede
Junior Member


Reged: 02/16/05
Posts: 7
Loc: Pune
Re: Basic OpenSTA Tutorial
      #295215 - 03/03/05 05:08 AM

Hi rajat,
Now my file uploading functionality in not working through openSTA. My tomcat throws error that it could not find the file on my physical location say... c:\<folder name>\ <file name>

But the same functionality works properly in normal run.Do u know why this problem is arising in openSTA.

...paresh


Post Extras: Print Post   Remind Me!   Notify Moderator  
Paresh Wankhede
Junior Member


Reged: 02/16/05
Posts: 7
Loc: Pune
Re: Basic OpenSTA Tutorial
      #295216 - 03/07/05 09:10 PM

hello there,
can any one plese tell me how to analyze the graphs generate by openSTA bcoz processor time , user time is going into -ve ie say -50% .. like that ...
..pls help...

...paresh


Post Extras: Print Post   Remind Me!   Notify Moderator  
dineshcanchi
Newbie


Reged: 04/20/09
Posts: 10
Basic OpenSTA Tutorial [Re: Paresh Wankhede]
      #565528 - 04/27/09 11:49 PM

hi paresh,


Yes paresh i have that problem ,can u help me out.

In the Gateway when i select local option, then the proxy option is read only and its showing the Ip address of some other local machine of our, so please can anyone suggest me on how to configure the Proxy to let it display my local machine IP. & port number.


Post Extras: Print Post   Remind Me!   Notify Moderator  
Pages: 1



Extra information
0 registered and 1 anonymous users are browsing this forum.

Moderator:  SteveKay, AJ, dansut, Bernie Velivis 

Print Topic

Forum Permissions
      You cannot start new topics
      You cannot reply to topics
      HTML is disabled
      UBBCode is enabled

Rating:
Topic views: 9523

Rate this topic

Jump to

Contact Us | Privacy statement SQAForums

Powered by UBB.threads™ 6.5.5