The online community for software testing & quality assurance professionals
 
 
Calendar   Today's Topics
Sponsors:




Lost Password?

Home
BetaSoft
Blogs
Jobs
Training
News
Links
Downloads



Testing Tools >> HP Functional Testing / Mercury QuickTest Pro / QTP

Pages: 1
acognard
Member


Reged: 06/20/07
Posts: 112
Loc: Europe, France, Lille
Shared Object with ALM
      #719847 - 11/15/12 04:36 AM

Hi all, i hope someone can help me.

While trying the code below :

Dim RepositoryFrom
Set RepositoryFrom = CreateObject("Mercury.ObjectRepositoryUtil")
PATH_OR ="[QualityCenter\Resources] Resources\BPT Resources\Object Repositories\"
sRepository = PATH_OR & "IC.tsr"
RepositoryFrom.Load sRepository

the message error appears
'Load' - General error.

Function file: [QualityCenter\Resources] Resources\BPT Resources\Libraries\IC\Lib_OR.qfl
Line (7): "RepositoryFrom.Load sRepository".

the path comes from a copy from path found into QTP Tools>options>Folders. The file name is ok.

I have no idea about this error.

tks in advance.
Arnaud

--------------------
Arnaud
idomotique
we make your dream

Edited by acognard (11/15/12 04:38 AM)


Post Extras: Print Post   Remind Me!   Notify Moderator  
satkha
Member


Reged: 07/21/10
Posts: 47
Loc: Kyiv
Re: Shared Object with ALM [Re: acognard]
      #719929 - 11/29/12 04:51 AM

As far as I see you are trying to do something with Object Repositories.
The error you are getting is connected to Libraries.
Could you double-check?

--------------------
All are not hunters that blow the horn


Post Extras: Print Post   Remind Me!   Notify Moderator  
MarcusS
Newbie


Reged: 03/24/09
Posts: 18
Loc: Germany, Duesseldorf
Re: Shared Object with ALM [Re: satkha]
      #719969 - 12/11/12 11:34 PM

Hi all,

Set oRepository = CreateObject("Mercury.ObjectRepositoryUtil")
For i = 1 to RepositoriesCollection.Count
oRepository.Load RepositoriesCollection.Item(i)
Set TOCollection = oRepository.GetChildren(JavaWindow("WindowName"))


This code shall do quiet the same as your, but the general error is the same. The "RepositoriesCollection.Item(i)" returns the path to the associated OR, but it seems that "<ObjectRepositoryUtil>.Load" is not able to use ALM paths.

Could anyone help?


Post Extras: Print Post   Remind Me!   Notify Moderator  
Pages: 1



Extra information
0 registered and 90 anonymous users are browsing this forum.

Moderator:  IanFraser, Rajkumar_Rajangam, thorwath, TReddy, AJ, Tarun Lalwani, mwsrosso 

Print Topic

Forum Permissions
      You cannot start new topics
      You cannot reply to topics
      HTML is disabled
      UBBCode is enabled

Rating:
Topic views: 4418

Rate this topic

Jump to

Contact Us | Privacy statement SQAForums

Powered by UBB.threads™ 6.5.5