The online community for software testing & quality assurance professionals
 
 
Calendar   Today's Topics
Sponsors:




Lost Password?

Home
BetaSoft
Blogs
Jobs
Training
News
Links
Downloads



Testing Tools >> HP Functional Testing / Mercury QuickTest Pro / QTP

Pages: 1
boliver46
Junior Member


Reged: 02/06/02
Posts: 259
Loc: Toledo, Ohio USA
QTP Locks Up on SSRS Front-End
      #572455 - 06/02/09 11:13 AM

Hi All,

I am using QTP 10.0 with all add-ins. When I try to record against SSRS, it is UBER slow. When attempting to playback, QTP and the app lockup - to the point I need to kill the QTP process. The strange thing is, the step I am trying to do is then executed AFTER QTP is killed (e.g. Setting the start date for a report range).

Does anyone know what might be going on? I am thinking there is a conflicting process or something, but just wondered if anyone had encountered this issue.

Thanks!

-Brett

--------------------
http://www.sqaforums.com/showflat.php?Cat=0&Number=590749&an=0&page=0#Post590749


Post Extras: Print Post   Remind Me!   Notify Moderator  
boliver46
Junior Member


Reged: 02/06/02
Posts: 259
Loc: Toledo, Ohio USA
Re: QTP Locks Up on SSRS Front-End [Re: boliver46]
      #579028 - 07/09/09 11:16 AM Attachment (251 downloads)

Ok all - this is an even BIGGER issue for me now, so was hoping to push this issue back out there in front of the general populace.

Has anyone had experience with automating against SQL Server Reporting Services? Basically at this point we are embedding the SSRS controls into a "generic" .aspx page - simple, right?

QTP records just fine on the embedded control - but on playback, it never does anything...and as stated above, when I STOP QTP, it performs the next step in the script. Weird right?

Anyways - I am SO hopeful someone has some experience with this issue or can help! File attached just a screenshot showing the embedded control.

Thanks in advance.

-Brett

--------------------
http://www.sqaforums.com/showflat.php?Cat=0&Number=590749&an=0&page=0#Post590749


Post Extras: Print Post   Remind Me!   Notify Moderator  
devstream
Member


Reged: 05/23/08
Posts: 136
Re: QTP Locks Up on SSRS Front-End [Re: boliver46]
      #579050 - 07/09/09 01:43 PM

are you using IE? if so, what version?

Post Extras: Print Post   Remind Me!   Notify Moderator  
boliver46
Junior Member


Reged: 02/06/02
Posts: 259
Loc: Toledo, Ohio USA
Re: QTP Locks Up on SSRS Front-End [Re: devstream]
      #579311 - 07/11/09 08:52 PM

I've tried it mainly in IE7.0 - but tried it Friday on IE 8.0 on a test machine and still the same issues.

--------------------
http://www.sqaforums.com/showflat.php?Cat=0&Number=590749&an=0&page=0#Post590749


Post Extras: Print Post   Remind Me!   Notify Moderator  
AO0148
Newbie


Reged: 03/09/10
Posts: 1
Re: QTP Locks Up on SSRS Front-End [Re: boliver46]
      #617046 - 03/09/10 03:42 PM

Hi boliver46,

Did you ever find the solution for:

"When I try to record against SSRS, it is UBER slow. When attempting to playback, QTP and the app lockup - to the point I need to kill the QTP process. The strange thing is, the step I am trying to do is then executed AFTER QTP is killed (e.g. Setting the start date for a report range)."

I too am experiencing a very similar challenge, and am at wits end trying to devise "work-arounds" to get past this hurdle.


Post Extras: Print Post   Remind Me!   Notify Moderator  
sui8
Newbie


Reged: 08/13/07
Posts: 1
Re: QTP Locks Up on SSRS Front-End [Re: AO0148]
      #625633 - 05/07/10 01:03 PM

We downgraded to IE6, and this issue went away. Hope this helps everyone that were stuck like we were.

Post Extras: Print Post   Remind Me!   Notify Moderator  
kaidong
Newbie


Reged: 09/04/09
Posts: 2
Re: QTP Locks Up on SSRS Front-End [Re: sui8]
      #675886 - 06/22/11 01:54 AM

One year has past, did anyone solved this issue?
I experience this issue in my project now.
It's so annoying!


Post Extras: Print Post   Remind Me!   Notify Moderator  
manojmathew1984
Newbie


Reged: 01/04/08
Posts: 4
Re: QTP Locks Up on SSRS Front-End [Re: kaidong]
      #679336 - 07/19/11 05:23 AM

I am facing the same issue. It seems like QTP captures the object and in object repository we can highlight the object without any delay. On run time, QTP takes around 3 mins to do any action on the page, even -- Browser("XYZ").Close

The test however gets executed after this huge delay.
may be a limitation of QTP running on SSRS screen.

I have to try what sui suggested, with IE6.

Anyone got a solution???


Post Extras: Print Post   Remind Me!   Notify Moderator  
qtp_prof
Newbie


Reged: 11/02/11
Posts: 3
Re: QTP Locks Up on SSRS Front-End [Re: manojmathew1984]
      #690077 - 11/02/11 05:01 AM

Hi,

Can anyone of you please tell me how I can connect to the ssrs reporting server from QTP?
Also please tell me what all features of the report can be tested?

Thanks


Post Extras: Print Post   Remind Me!   Notify Moderator  
AmbujGoel
Newbie


Reged: 12/06/12
Posts: 1
Re: QTP Locks Up on SSRS Front-End [Re: manojmathew1984]
      #719958 - 12/06/12 09:02 PM

Hi, Still I can't see any solution on the same. I tried with QTP 11 version with IE8 and got no resolution

Post Extras: Print Post   Remind Me!   Notify Moderator  
Pages: 1



Extra information
0 registered and 65 anonymous users are browsing this forum.

Moderator:  IanFraser, Rajkumar_Rajangam, thorwath, TReddy, AJ, Tarun Lalwani, mwsrosso 

Print Topic

Forum Permissions
      You cannot start new topics
      You cannot reply to topics
      HTML is disabled
      UBBCode is enabled

Rating:
Topic views: 8651

Rate this topic

Jump to

Contact Us | Privacy statement SQAForums

Powered by UBB.threads™ 6.5.5