The online community for software testing & quality assurance professionals
 
 
Calendar   Today's Topics
Sponsors:




Lost Password?

Home
BetaSoft
Blogs
Jobs
Training
News
Links
Downloads



Testing Tools >> HP Functional Testing / Mercury QuickTest Pro / QTP

Pages: 1 | 2 | (show all)
GregEncke
Member


Reged: 02/11/08
Posts: 277
Loc: Seattle, WA
Re: QTP 11 cannot recognize .NET or WPF objects [Re: QTP_Guru]
      #705019 - 04/24/12 08:53 AM

My .net problems started when I downloaded patch QTPWEB_00078. I uninstalled the patch and .net is working again. (uninstalled ie9 for the moment) Thanks for letting me know about the secret patches, I'll contact HP to aquire them.

--------------------
Patience is like bread I say.... I ran out of that yesterday.


Post Extras: Print Post   Remind Me!   Notify Moderator  
lavneesh
Newbie


Reged: 07/23/12
Posts: 14
Re: QTP 11 cannot recognize .NET or WPF objects [Re: QTP_Guru]
      #712818 - 07/23/12 07:21 AM

QTP has a hard time in recognizing many of the applications built using MFC. I faced a similar situation at work and what we did to tackle this scenario was to tweak QTP's object identification. From the "Tools -> Object Identification" menu you can map all the unrecognized objects to known objects and use these unrecognized objects as your mapped known object thereafter.

Post Extras: Print Post   Remind Me!   Notify Moderator  
meghanageorge
Newbie


Reged: 08/20/12
Posts: 1
Re: QTP 11 cannot recognize .NET or WPF objects [Re: IncantatrixQA]
      #714836 - 08/20/12 12:46 AM

I've just gotten hold of the QTP 11 trial and among other problems, it doesn't seem to record anything when ran against our software. The app's .NET based so I'm guessing it's related to this issue but despite spending hours going in circles on the HP support site I can't for the life of me figure out how to access patches. I've tried googling, I've ran the in-app updater and no joy.

Any ideas?


Post Extras: Print Post   Remind Me!   Notify Moderator  
ttguy
Member


Reged: 01/28/09
Posts: 267
Loc: Canberra
Re: QTP 11 cannot recognize .NET or WPF objects [Re: meghanageorge]
      #715040 - 08/22/12 06:16 PM

Quote:

I've just gotten hold of the QTP 11 trial and among other problems, it doesn't seem to record anything when ran against our software. The app's .NET based so I'm guessing it's related to this issue but despite spending hours going in circles on the HP support site I can't for the life of me figure out how to access patches. I've tried googling, I've ran the in-app updater and no joy.

Any ideas?




You quite often have to ask for a patch by number from a service request that you raise. Many of the patches mentioned in this thread are not "public". You can not find out about them from searching HPs site. You only find out about them when someone mentions them on some internet forum like this one.

I don't know why. I guess HP are embarrased by the number of patches required to fix things in QTP.


Post Extras: Print Post   Remind Me!   Notify Moderator  
Ibrez
Newbie


Reged: 09/17/12
Posts: 4
Re: QTP 11 cannot recognize .NET or WPF objects [Re: QTP_Guru]
      #716562 - 09/17/12 11:31 AM

We did face a similar issue in our WPF application on Win XP.
The problem seems to mysteriously disappear when the application is started after starting QTP, and from them onwards the WPFButton etc objects were recognised. Although on one particular Win xP virtual system the problem is still persistent.

I don't know if you have already tried the above approach. if not give it a try


Post Extras: Print Post   Remind Me!   Notify Moderator  
SatishMathpal
Newbie


Reged: 12/06/12
Posts: 1
Re: QTP 11 cannot recognize .NET or WPF objects [Re: QTP_Guru]
      #719957 - 12/06/12 05:21 PM

I have been seeing so many posts above for WPF objects identification with QTP11. I have recently faced same issue and found the solution.

I had 32 bit .Net 4.0 based windows application with 99% WPF and couple of ActiveX objects. I selected the .Net and WPF addin but couldn't get success in identifying objects. Went through several forums and found QTP_00709 patch as solution. I installed QTP_00709 path and QTP 11 started identifying couple of screens but not all. Also i was not able to record anything.

After all the attempts i put my case to HP and they provided one path(QTPNET_00113 - Accumulative Hotfix for the WPF Add-in ) which is released specially for WPF based applications.

I installed this patch on the top of QTP_00709 and got success in identifying all WPF objects. Also QTP was able to record all the screens.

Following are the prerequisite to be done before recording:
For very first time while recording make the below setting:
Go to Record and Run Setting -> Windows application
Record and run only on:
check the box for "Application opened by Quick test"
Check the box for "Application specified below" and add your application in Application details section.

Next time onwards when you record you can choose the option "Record and run test on any...." and it works fine.

Hope it helps!!


Post Extras: Print Post   Remind Me!   Notify Moderator  
Pages: 1 | 2 | (show all)



Extra information
0 registered and 65 anonymous users are browsing this forum.

Moderator:  IanFraser, Rajkumar_Rajangam, thorwath, TReddy, AJ, Tarun Lalwani, mwsrosso 

Print Topic

Forum Permissions
      You cannot start new topics
      You cannot reply to topics
      HTML is disabled
      UBBCode is enabled

Rating: ***
Topic views: 37171

Rate this topic

Jump to

Contact Us | Privacy statement SQAForums

Powered by UBB.threads™ 6.5.5