The online community for software testing & quality assurance professionals
 
 
Calendar   Today's Topics
Sponsors:




Lost Password?

Home
BetaSoft
Blogs
Jobs
Training
News
Links
Downloads



Testing Tools >> Micro Focus/Borland/Segue SilkTest

Pages: 1
fkmfkm
Newbie


Reged: 06/28/12
Posts: 19
SilkTest and ZK framework
      #719269 - 11/05/12 01:33 AM

Hi,

Has anyone tried SilkTest on ZK framework application before ?

How do you all solve the ID problems ?


Post Extras: Print Post   Remind Me!   Notify Moderator  
gecki
Member


Reged: 02/08/09
Posts: 85
Re: SilkTest and ZK framework [Re: fkmfkm]
      #719431 - 11/07/12 02:17 AM

Hi,

You might want to not use the generated IDs as identifies in the test scripts. Therefore you can tell SilkTest to not use the "id" attribute when it creates an locator (e.g during recording).

You can do this as follows:
* in SilkTest Workbench: Open Tools > Options > Record > xBrowser. Add id attribute to the "Locator attribute name exclude list" text field
* in Silk4J/Silk4NET/SilkTest Classic: Open the options dialog, select the "Browser" tab and add the id attribute to the "Locator attribute name exclude list" text field


Post Extras: Print Post   Remind Me!   Notify Moderator  
Pages: 1



Extra information
0 registered and 9 anonymous users are browsing this forum.

Moderator:  AJ, jamesso, DJGray, David Reed 

Print Topic

Forum Permissions
      You cannot start new topics
      You cannot reply to topics
      HTML is disabled
      UBBCode is enabled

Rating:
Topic views: 1768

Rate this topic

Jump to

Contact Us | Privacy statement SQAForums

Powered by UBB.threads™ 6.5.5