The online community for software testing & quality assurance professionals
 
 
Calendar   Today's Topics
Sponsors:




Lost Password?

Home
BetaSoft
Blogs
Jobs
Training
News
Links
Downloads



Testing Tools >> HP / Mercury LoadRunner

Pages: 1
AdenSia
Newbie


Reged: 10/23/12
Posts: 5
LRScript issue-Java Script Enabled Browser requird
      #718886 - 10/29/12 04:41 AM

Hi All,

I need to test the performance of Oracle Finance Application (R12). I have used the protocols "Oracle NCA and HTTP/HTTPS" for scripting. I was able to script but while replaying I am getting an error message "Java Script Enabled Browser required". IE 8 browser is used for replay. I have verified that the "Scripting" parameter is enabled in IE 8. The application is working fine manuallay.

If anybody experience same issue, please share your experience.

Thanks,
Adensia

Required detials

1.LR v11.0

2. What is the protocol you are recording?
Oracle NCA and HTTP/HTTPS
3. HTML-Advanced with explicit URLs - yes

4. If URL mode: - Concurrent groups

5. Which LoadRunner/PerformanceCenter feature (FPs) or service packs are you using?
(List details here) none

6. VuGen Recording - New

7. What kind of LoadRunner license do you have -

- Permanent,

8. current


Post Extras: Print Post   Remind Me!   Notify Moderator  
James PulleyModerator
Moderator


Reged: 08/01/01
Posts: 5551
Loc: NC
Re: LRScript issue-Java Script Enabled Browser requird [Re: AdenSia]
      #718890 - 10/29/12 05:52 AM

Training in loadrunner?

Post Extras: Print Post   Remind Me!   Notify Moderator  
AdenSia
Newbie


Reged: 10/23/12
Posts: 5
Re: LRScript issue-Java Script Enabled Browser requird [Re: James Pulley]
      #718938 - 10/29/12 09:50 PM

No....I am not looking for any training. I have explained a strange issue I am facing.

I am getting below error message while replying the script.

"Java Script Enabled Browser required" in the view result window in Vugen.

I am not getting this error message while running the application manually in the same browser. I like to get a solution for this issue.

Thanks,
Adensia


Post Extras: Print Post   Remind Me!   Notify Moderator  
James PulleyModerator
Moderator


Reged: 08/01/01
Posts: 5551
Loc: NC
Re: LRScript issue-Java Script Enabled Browser requird [Re: AdenSia]
      #718967 - 10/30/12 03:22 AM

Run time browser?

Post Extras: Print Post   Remind Me!   Notify Moderator  
AdenSia
Newbie


Reged: 10/23/12
Posts: 5
Re: LRScript issue-Java Script Enabled Browser requird [Re: James Pulley]
      #718968 - 10/30/12 03:28 AM

I have used IE 8 as runtime browser. Same browser I am using for running the application manually where its working fine.

I have tried with different protocols like Web (HTTP), Ajax etc. Same issue is existing.

Also I hae verified in the browser that Active Scripting is enabled in Custom level setting in IE 8.


Post Extras: Print Post   Remind Me!   Notify Moderator  
James PulleyModerator
Moderator


Reged: 08/01/01
Posts: 5551
Loc: NC
Re: LRScript issue-Java Script Enabled Browser requird [Re: AdenSia]
      #718977 - 10/30/12 04:42 AM

LoadRunner does not use IE for a run time browser, it has its own built in. Setting the browser settings in the run time setting basically alters the browser announcement string used to the server (shows up in the logs) and is only useful if you have conditional dynamic page generation based upon the browser type and version. You may test this by setting it to "AdenSia v10" as the browser type.

Back to the core issue, assuming you have the run time browser option selected, is this issue occurring when you execute your script?


Post Extras: Print Post   Remind Me!   Notify Moderator  
AdenSia
Newbie


Reged: 10/23/12
Posts: 5
Re: LRScript issue-Java Script Enabled Browser requird [Re: James Pulley]
      #718980 - 10/30/12 05:45 AM

Thanks for your reply....

The issue I am facing while executing the scipt in Vugen (didn't try in Controller). I have selected IE 8 Browser in run time setting in Vugen.

I think Vugen is using the browser installed in the system for script execution (in this case IE 8) and Controller is using the API during execution. Please correct if I am wrong.


Post Extras: Print Post   Remind Me!   Notify Moderator  
James PulleyModerator
Moderator


Reged: 08/01/01
Posts: 5551
Loc: NC
Re: LRScript issue-Java Script Enabled Browser requird [Re: AdenSia]
      #718985 - 10/30/12 06:21 AM

You are incorrect. Please refer to your VUGEN Web Virtual User Training Class documentation for information on the limitations of the run time browser in VUGEN.

Post Extras: Print Post   Remind Me!   Notify Moderator  
AdenSia
Newbie


Reged: 10/23/12
Posts: 5
Re: LRScript issue-Java Script Enabled Browser requird [Re: James Pulley]
      #719573 - 11/08/12 09:37 PM

The issue got resolved after using the protocol Ajax Trueclient. Now the error is not coming.

Post Extras: Print Post   Remind Me!   Notify Moderator  
James PulleyModerator
Moderator


Reged: 08/01/01
Posts: 5551
Loc: NC
Re: LRScript issue-Java Script Enabled Browser requird [Re: AdenSia]
      #719593 - 11/09/12 05:21 AM

And your tradeoff for not understanding the nature of the error is likely an order of magnitude reduction in the number of virtual users you may execute per load generator

Go back and fortify your unerstanding of client application architecture in general and web client architecture in specific. Your questions have exposed a weakness in this area you need to address. The same holds true for your working knowledge of LoadRunner


Post Extras: Print Post   Remind Me!   Notify Moderator  
Pages: 1



Extra information
0 registered and 34 anonymous users are browsing this forum.

Moderator:  AJ, James Pulley, ptrussell_nc, JimHowell1970 

Print Topic

Forum Permissions
      You cannot start new topics
      You cannot reply to topics
      HTML is disabled
      UBBCode is enabled

Rating:
Topic views: 4541

Rate this topic

Jump to

Contact Us | Privacy statement SQAForums

Powered by UBB.threads™ 6.5.5