The online community for software testing & quality assurance professionals
 
 
Calendar   Today's Topics
Sponsors:




Lost Password?

Home
BetaSoft
Blogs
Jobs
Training
News
Links
Downloads



Testing Tools >> Micro Focus/Compuware TestPartner

Pages: 1
sahanaveeru
Newbie


Reged: 07/15/10
Posts: 5
issue in executing the test scripts in batch run
      #660340 - 02/13/11 07:32 PM

Hi All,
I am using Test partner 6.3-183 Build for execution of scripts.
When i run the scripts individually, it goes fine but when i tried to run batch, the scripts are going to fail due to some reason as window doesn't have a menu, button not found.
this behavior is dynamic.
Please let me know the reason for this..asap..

Sahana


Post Extras: Print Post   Remind Me!   Notify Moderator  
SantozSoftware
Newbie


Reged: 12/13/10
Posts: 13
Re: issue in executing the test scripts in batch run [Re: sahanaveeru]
      #661424 - 02/22/11 02:26 AM

Hi,

Is end location of first script same as beginning location of the next script?for example
script1 : start on Page1, end on Page2
script2 : start on Page2, end on Page4
script3 : start on Page4, end on Page3

If they are starting from different locations, you should start and end your scripts from same location( for example to form login or form default )


Post Extras: Print Post   Remind Me!   Notify Moderator  
sahanaveeru
Newbie


Reged: 07/15/10
Posts: 5
Re: issue in executing the test scripts in batch run [Re: SantozSoftware]
      #661568 - 02/22/11 11:58 PM

Thank you for Replying..

I am using KRD approach.
Scripts are located in the same folder named as Script, which will be mentioned in Active Data.
and each script is written in separate Excel sheet.

For eg :

Script1: Script1.xls located in C:\Testpartner\Script
Script2: Script2.xls located in C:\Testpartner\Script

Please suggest me on this..
Sahana


Post Extras: Print Post   Remind Me!   Notify Moderator  
SantozSoftware
Newbie


Reged: 12/13/10
Posts: 13
Re: issue in executing the test scripts in batch run [Re: sahanaveeru]
      #662335 - 02/28/11 07:38 PM

Quote:

Thank you for Replying..

I am using KRD approach.
Scripts are located in the same folder named as Script, which will be mentioned in Active Data.
and each script is written in separate Excel sheet.

For eg :

Script1: Script1.xls located in C:\Testpartner\Script
Script2: Script2.xls located in C:\Testpartner\Script

Please suggest me on this..
Sahana




sorry for asking. What is KRD approach?Is that methodology to running TestPartner script from xls files??


Post Extras: Print Post   Remind Me!   Notify Moderator  
sahanaveeru
Newbie


Reged: 07/15/10
Posts: 5
Re: issue in executing the test scripts in batch run [Re: SantozSoftware]
      #663523 - 03/08/11 07:06 PM

Hi,

KRD is keyword driven approach. The scripts are created using Keywords which are defined in the framework of test partner according to the appication.
this methodology will be running from Excel sheet where the script has been written.


Post Extras: Print Post   Remind Me!   Notify Moderator  
sahanaveeru
Newbie


Reged: 07/15/10
Posts: 5
Halts execution when remote desktop isdisconnected [Re: sahanaveeru]
      #718012 - 10/15/12 02:52 AM

Hi,

I am executing automation scripts in batchrun in testing machine.

When i start for Batch run of scripts and disconnect from that machine,(i.e at night if i give for running bunch of script and disconnect from that machine) the execution of script halts there and when i reconnect , it will resume the execution and goes fine.

Please let me know what is the cause and solution for this!

Your reply would be appreciated..
Sahana

Edited by sahanaveeru (10/15/12 03:31 AM)


Post Extras: Print Post   Remind Me!   Notify Moderator  
PG_Vishnu
Newbie


Reged: 10/26/12
Posts: 1
Re: Halts execution when remote desktop isdisconnected [Re: sahanaveeru]
      #718822 - 10/26/12 11:13 AM

Hi,
Yes sahanaveeru, even i am getting the same issue, but in my case it is a bit different:

When it is disconnected, the script takes more (very large) time whereas which takes only 1/5th while unit testing.

Can any one comment on this?


Post Extras: Print Post   Remind Me!   Notify Moderator  
Pages: 1



Extra information
0 registered and 5 anonymous users are browsing this forum.

Moderator:  Myrtle, Jim Brennan, AJ, DSquared 

Print Topic

Forum Permissions
      You cannot start new topics
      You cannot reply to topics
      HTML is disabled
      UBBCode is enabled

Rating:
Topic views: 4752

Rate this topic

Jump to

Contact Us | Privacy statement SQAForums

Powered by UBB.threads™ 6.5.5