The online community for software testing & quality assurance professionals
 
 
Calendar   Today's Topics
Sponsors:




Lost Password?

Home
BetaSoft
Blogs
Jobs
Training
News
Links
Downloads



Testing Tools >> Micro Focus/Compuware TestPartner

Pages: 1 | 2 | (show all)
JeffCull
Newbie


Reged: 06/01/11
Posts: 2
Re: taking screenshots in test partner [Re: tubaloth]
      #679419 - 07/19/11 01:32 PM


I have done this recently, and the way i went about it was with a tool I found online called CommandCapture (CMDCapture). Google it and i am sure you will find it. It is a simple exe that will capture the whole screen when ran from the commandline (or with a shell command from TP). Worked out really well.


Post Extras: Print Post   Remind Me!   Notify Moderator  
asleep
Newbie


Reged: 05/10/07
Posts: 1
Re: taking screenshots in test partner [Re: tubaloth]
      #680811 - 08/01/11 04:24 PM

One thing that I've done to grab is screen shot when errors occur is to do a bitmap check comparing it blank image. It's very convenient because the screen shot is tied directly to the individual results. No need for third party solutions.

Post Extras: Print Post   Remind Me!   Notify Moderator  
JMI
Advanced Member


Reged: 11/06/02
Posts: 537
Loc: Lausanne, Switzerland
Re: taking screenshots in test partner [Re: Aracknid]
      #711335 - 07/03/12 06:11 AM

Quote:

Certainly, you should not expect any updates to the code, as it is over 4 years old already. If anything, I'd advise you not to use this. Once you become dependant on it, you will really be in a jam should it stop working in a later release (update) of TestPartner.




Well, I am dependant on TPHelperCommands and I begin to try my TestPartner scripts on Windows7. I get the "ActiveX component can't create object" error while trying to create one of HelperCmds objects.

Does any of you use TestPartner with TPHelperCommands on Windows7?

I use TestPartner 6.1 (Build 7601) Service Pack 1.
My scripts work well on Windows XP.


Post Extras: Print Post   Remind Me!   Notify Moderator  
lslackware
Newbie


Reged: 08/17/12
Posts: 6
Re: taking screenshots in test partner [Re: tubaloth]
      #714768 - 08/17/12 04:03 AM

My solution is to use autoit for this:
Just compile some small autoit utility:
Code:

#include <ScreenCapture.au3>
If $CMDLINE[0] = 1 Then
$filename = $CMDLINE[1]
_ScreenCapture_SetJPGQuality(50)
_ScreenCapture_Capture($filename)
EndIf


After that, from windows cmd run command "path_to_your_folder\screenshot.exe" "C:\somefolder\my_screenshot.jpg"

N.B. screenshot quality in this example is reduced to 50%.
Also, don't forget about autoit library ScreenCapture.au3 which is needed for this example

Edited by lslackware (08/17/12 04:04 AM)


Post Extras: Print Post   Remind Me!   Notify Moderator  
JMI
Advanced Member


Reged: 11/06/02
Posts: 537
Loc: Lausanne, Switzerland
Re: taking screenshots in test partner [Re: lslackware]
      #715565 - 08/30/12 03:08 AM

My problem with TPHelperCommands on Windows7 machine was due to TPHelperCommands being a 32 bit DLL while my machine is 64 bit... I found a recipe for installing 32bit DLLs on Windows7 64bit (thank you, Google!) and it works OK.
Well, almost - I could not make screen copies in the JPEG format, so I do them as Bitmap now.


Post Extras: Print Post   Remind Me!   Notify Moderator  
tubaloth
Member


Reged: 02/13/07
Posts: 261
Re: taking screenshots in test partner [Re: JMI]
      #716440 - 09/13/12 11:43 AM

Quote:

My problem with TPHelperCommands on Windows7 machine was due to TPHelperCommands being a 32 bit DLL while my machine is 64 bit... I found a recipe for installing 32bit DLLs on Windows7 64bit (thank you, Google!) and it works OK.
Well, almost - I could not make screen copies in the JPEG format, so I do them as Bitmap now.




I was a little worried about this, with me getting a Windows 7 machine.

I just installed/unziped the TPHelper commands fine. I had change a couple of scripts to reference the Snapshot function. But its taking screen shots just like before (in JPG). I was just reminded of this when it took a screen shot a full 1920 x 1080.


Post Extras: Print Post   Remind Me!   Notify Moderator  
Pages: 1 | 2 | (show all)



Extra information
0 registered and 5 anonymous users are browsing this forum.

Moderator:  Myrtle, Jim Brennan, AJ, DSquared 

Print Topic

Forum Permissions
      You cannot start new topics
      You cannot reply to topics
      HTML is disabled
      UBBCode is enabled

Rating:
Topic views: 21294

Rate this topic

Jump to

Contact Us | Privacy statement SQAForums

Powered by UBB.threads™ 6.5.5