The online community for software testing & quality assurance professionals
 
 
Calendar   Today's Topics
Sponsors:




Lost Password?

Home
BetaSoft
Blogs
Jobs
Training
News
Links
Downloads



Testing Tools >> OpenSTA

Pages: 1
Maumita
Newbie


Reged: 01/03/08
Posts: 5
Open STA Script Compiling problems
      #462105 - 02/28/08 12:51 AM

Hi!

I am new in Open STA.I have big problems playing a test in the latest version of openSTA (1.4.4).
Setup is :-
OS:- Windows 2003
IE 6 SP2
Open STA (1.4.4)
I cannot compile the script. I record a simple test script, going to www.google.se<http://www.google.se> and seacrh for somthing, then stop the recording. When I replay this script I get compile error ---

"User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.2; SV1; .NET CLR 1.1.4322; .NET CLR 2.0.50727; .NET CLR 3.0.04506.30;
*************************************************************************************************************************************
F:\Program Files\OpenSTA\Repository\Scripts\NEWSCRIPT.HTP(21) : error (badrecsiz), Source Line is Too Long

CONSTANT S_cookie_1_0 = &
**************************
F:\Program Files\OpenSTA\Repository\Scripts\NEWSCRIPT.HTP(22) : error (exttxt), Unexpected Text Encountered Following Statement

"PREF=ID=8ba2864d58fa011c:TM=1204170527:LM=1204170527:S=q5QDCUOl7YFlaPRJ"
*************************************************************************
F:\Program Files\OpenSTA\Repository\Scripts\NEWSCRIPT.HTP(23) : error (invdefcmnd), Invalid Definition Section Command

"Cookie: "+S_cookie_1_0}
************
F:\Program Files\OpenSTA\Repository\Scripts\NEWSCRIPT.HTP(44) : error (undefvar), Undefined Variable

Into blob_1_0 &
******** *
F:\Program Files\OpenSTA\Repository\Scripts\NEWSCRIPT.HTP(63) : error (undefvar), Undefined Variable
F:\Program Files\OpenSTA\Repository\Scripts\NEWSCRIPT.HTP(63) : error (exttxt), Unexpected Text Encountered Following Statement

,WITH "Proxy-Authenticate"
**************************
F:\Program Files\OpenSTA\Repository\Scripts\NEWSCRIPT.HTP(64) : error (invcmnd), Invalid Command

Into blob_2_0 &
******** *
F:\Program Files\OpenSTA\Repository\Scripts\NEWSCRIPT.HTP(122) : error (undefvar), Undefined Variable
F:\Program Files\OpenSTA\Repository\Scripts\NEWSCRIPT.HTP(122) : error (exttxt), Unexpected Text Encountered Following Statement

,WITH "Proxy-Authenticate"
**************************
F:\Program Files\OpenSTA\Repository\Scripts\NEWSCRIPT.HTP(123) : error (invcmnd), Invalid Command

Into blob_3_0 &
******** *
F:\Program Files\OpenSTA\Repository\Scripts\NEWSCRIPT.HTP(177) : error (undefvar), Undefined Variable
F:\Program Files\OpenSTA\Repository\Scripts\NEWSCRIPT.HTP(177) : error (exttxt), Unexpected Text Encountered Following Statement

,WITH "Proxy-Authenticate"
**************************
F:\Program Files\OpenSTA\Repository\Scripts\NEWSCRIPT.HTP(178) : error (invcmnd), Invalid Command

Into blob_4_0 &
******** *
F:\Program Files\OpenSTA\Repository\Scripts\NEWSCRIPT.HTP(229) : error (undefvar), Undefined Variable
F:\Program Files\OpenSTA\Repository\Scripts\NEWSCRIPT.HTP(229) : error (exttxt), Unexpected Text Encountered Following Statement

,WITH "Proxy-Authenticate"
**************************
F:\Program Files\OpenSTA\Repository\Scripts\NEWSCRIPT.HTP(230) : error (invcmnd), Invalid Command
scl: info (endnoobj), F:\Program Files\OpenSTA\Repository\Scripts\NEWSCRIPT.HTP Completed with 16 Diagnostics - Object Deleted

Edited by Maumita (02/28/08 04:47 AM)


Post Extras: Print Post   Remind Me!   Notify Moderator  
Bernie VelivisModerator
Moderator


Reged: 06/02/03
Posts: 1604
Loc: Hollis, NH, USA
Re: Open STA Script Compiling problems [Re: Maumita]
      #462977 - 03/02/08 02:31 PM

Try searching for threads that discuss "Source Line is Too Long" errors

--------------------
Bernie Velivis, Performax Inc
Bernie's blog


Post Extras: Print Post   Remind Me!   Notify Moderator  
amity1234
Newbie


Reged: 03/19/08
Posts: 24
Re: Open STA Script Compiling problems [Re: Bernie Velivis]
      #468080 - 03/19/08 03:23 AM

in the compilation it will give the line no. see that line u can find out some thing

Post Extras: Print Post   Remind Me!   Notify Moderator  
Bernie VelivisModerator
Moderator


Reged: 06/02/03
Posts: 1604
Loc: Hollis, NH, USA
Re: Open STA Script Compiling problems [Re: amity1234]
      #469959 - 03/26/08 08:14 AM

Or you could read the first sticky topic in this forum with the title "Source line is too long". This is a well know problem and very easy to fix.

--------------------
Bernie Velivis, Performax Inc
Bernie's blog


Post Extras: Print Post   Remind Me!   Notify Moderator  
dhanasekarkj
Newbie


Reged: 05/27/08
Posts: 5
Re: Open STA Script Compiling problems [Re: Bernie Velivis]
      #486469 - 05/27/08 11:45 PM

"User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.2; SV1; .NET CLR 1.1.4322; .NET CLR 2.0.50727; .NET CLR 3.0.04506.30;

Hi,

Its bcoz the length of source line is too long. Reduce the lenght of string by deleting some text in that. it will workfine.


Rgds,
Dhanasekar.k.j


Post Extras: Print Post   Remind Me!   Notify Moderator  
takesaber
Newbie


Reged: 02/26/08
Posts: 21
Re: Open STA Script Compiling problems [Re: dhanasekarkj]
      #486475 - 05/27/08 11:59 PM

Dont try recod and playback on Google try on some intranet site or other sites which are not well known.

Post Extras: Print Post   Remind Me!   Notify Moderator  
goozturk
Newbie


Reged: 02/14/09
Posts: 1
Re: Open STA Script Compiling problems [Re: takesaber]
      #568165 - 05/11/09 04:44 AM

You don't need to delete any text from the "User-Agent: Mozilla/4.0 ......." line, just cut it from the middle and paste the rest to the below line.

Post Extras: Print Post   Remind Me!   Notify Moderator  
Bernie VelivisModerator
Moderator


Reged: 06/02/03
Posts: 1604
Loc: Hollis, NH, USA
Re: Open STA Script Compiling problems [Re: goozturk]
      #568188 - 05/11/09 05:33 AM

Good advice, Goozturk. A year late, but still good advice Welcome to the OpenSTA forum.

--------------------
Bernie Velivis, Performax Inc
Bernie's blog


Post Extras: Print Post   Remind Me!   Notify Moderator  
sankumarsingh
Newbie


Reged: 06/14/11
Posts: 1
Re: Open STA Script Compiling problems [Re: Bernie Velivis]
      #702062 - 03/21/12 07:03 AM

Agree with goozturk ...Just append quote " in the left most end and " & in the right most end of each new line you have created.

e.g.
CONSTANT DEFAULT_HEADERS = "Host: 125.69.99.99^J" &
"Accept-Encoding: gzip, deflate^J" &
"User-Agent: Mozilla/4.0 (compatible; MSIE 8.0;" &
"Windows NT 5.1; Trident/4.0; BTRS122327; .NET4.0C;" &
".NET CLR 1.1.4322; .NET CLR 2.0.50727;" &
".NET CLR 3.0.4506.2152; .NET CLR 3.5.30729; InfoPath.3)"


Post Extras: Print Post   Remind Me!   Notify Moderator  
Pages: 1



Extra information
0 registered and 4 anonymous users are browsing this forum.

Moderator:  SteveKay, AJ, dansut, Bernie Velivis 

Print Topic

Forum Permissions
      You cannot start new topics
      You cannot reply to topics
      HTML is disabled
      UBBCode is enabled

Rating:
Topic views: 8989

Rate this topic

Jump to

Contact Us | Privacy statement SQAForums

Powered by UBB.threads™ 6.5.5