The online community for software testing & quality assurance professionals
 
 
Calendar   Today's Topics
Sponsors:




Lost Password?

Home
BetaSoft
Blogs
Jobs
Training
News
Links
Downloads



Testing Tools >> Micro Focus/Compuware QALoad

Pages: 1
PmDFeger
Member


Reged: 09/07/07
Posts: 44
Vuser to wait till page is fully loaded
      #682025 - 08/12/11 10:18 AM

I'm using QALoad 5.9

I looked through the forum and I cannot find an answer to my question.

Is there a way besides trying to use sleep for a vuser to wait until a page is fully loaded before doing an extract?

In other words, on a page I do an extract for a value, in this case its a dynamic hostid. Later on in the script, about 3 pages down, I use the extracted value. When I run the script I receive could not extract, or could not find the following extract.

If I run the script in the workbench it works. If I run it slowly in the conductor it works. If I have to much load, it doesn't. Most likely that's a webserver error. However I just want my VUser to wait at page 3 while page 4 loads.

thanks,
Scott


Post Extras: Print Post   Remind Me!   Notify Moderator  
drazle
Active Member


Reged: 11/30/00
Posts: 829
Loc: Michigan, USA
Re: Vuser to wait till page is fully loaded [Re: PmDFeger]
      #682599 - 08/19/11 05:41 AM

My understanding is that the extract will not occur until the page is loaded. I believe this is the default behavior and in fact I don't think that it can be overridden.

You may be seeing an error due to load. Does this happen for every VU when under load? If so, you should be able to observe it manually by doing the transaction yourself while QALoad is running.

When you say "slowly in conductor" and "much load" what does that mean? Is slowly the same number of users with higher sleep time, or is it number of users? What I'm wondering is if it is number of users because I've found errors I'd introduced into scripts that only exhibited when I ran more than 1 VU.

When you run it in Workbench or "slowly" in Conductor or you doing more than 1 transaction? Wondering if the error only occurs after the first transaction which would be an issue with where the transaction loop is placed. I have seen instances where the transaction loop defined in the Visual Navigator is actually in the wrong spot and has to be modified in an editable script.

Just some ideas, may have more if you provide more info.

--------------------
A problem is a difference between what is perceived and what is desired, that
we want to reduce
(Dewey 1933)


Post Extras: Print Post   Remind Me!   Notify Moderator  
Pages: 1



Extra information
0 registered and 1 anonymous users are browsing this forum.

Moderator:  AJ, DSquared 

Print Topic

Forum Permissions
      You cannot start new topics
      You cannot reply to topics
      HTML is disabled
      UBBCode is enabled

Rating:
Topic views: 2429

Rate this topic

Jump to

Contact Us | Privacy statement SQAForums

Powered by UBB.threads™ 6.5.5