The online community for software testing & quality assurance professionals
 
 
Calendar   Today's Topics
Sponsors:




Lost Password?

Home
BetaSoft
Blogs
Jobs
Training
News
Links
Downloads



Testing Tools >> Micro Focus/Compuware QALoad

Pages: 1
priyaganesh
Newbie


Reged: 09/10/10
Posts: 8
Reg: Microstrategy Application
      #668431 - 04/17/11 11:32 PM

Hi All,

we are using QALoad 5.9 for capturing Microstrategy application. every we execute it is failing in the page check. even we tried hard coding all the values instead of server response handling but still it is failing in the page tittle. please do me in this.

Thanks and Regards
Priya Ganesh


Post Extras: Print Post   Remind Me!   Notify Moderator  
priyaganesh
Newbie


Reged: 09/10/10
Posts: 8
Re: Reg: Microstrategy Application [Re: priyaganesh]
      #668432 - 04/17/11 11:46 PM

sorry it is QALoad5.8 build 352 it is not 5.9

Post Extras: Print Post   Remind Me!   Notify Moderator  
drazle
Active Member


Reged: 11/30/00
Posts: 829
Loc: Michigan, USA
Re: Reg: Microstrategy Application [Re: priyaganesh]
      #668636 - 04/19/11 05:04 AM

Is the page title different each time?

--------------------
A problem is a difference between what is perceived and what is desired, that
we want to reduce
(Dewey 1933)


Post Extras: Print Post   Remind Me!   Notify Moderator  
priyaganesh
Newbie


Reged: 09/10/10
Posts: 8
Re: Reg: Microstrategy Application [Re: drazle]
      #669313 - 04/26/11 02:25 AM

No the page title remains constant. we have two servers in the production and use load balancing concepts. is there anything to do with load balancing? we really stuck in this stage and coulds not even identify which id is actually changing. we raised this issue to microfocus they said that some id's are not handled and need server log files to check or ask application team help. please do help us in this regard.

Thanks and Regards
Priya.S


Post Extras: Print Post   Remind Me!   Notify Moderator  
drazle
Active Member


Reged: 11/30/00
Posts: 829
Loc: Michigan, USA
Re: Reg: Microstrategy Application [Re: priyaganesh]
      #669355 - 04/26/11 06:40 AM

I'm not clear what load balancing would have to do with the page title - usually load balancing is transparent to the user (in this case the page title).

If you turn off page title validation, does it then work?

My guess from your response above is that this has more to do with session/cookies than the page title.

Also, if it is a load balancing problem, then it should be "intermittant," that is it should work sometimes.

All server responses are available to QALoad, just like a browser. So there may be some server parameter that you haven't captured/passed back correctly. I highly recommend that you install a HTTP proxy capture tool (like Fiddler ) and setup your workbench script to go through that proxy (and remeber to disable that before running on a player agent). You should be able to determine all the values being passed back to the server this way.

Is it java or ASP.Net or what kind of web app? I have seen several java apps that have a "blank" page that is loaded inbetween pages. This make parameterization more work as you have to capture to a variable, then pass back in the request following the blank page. Do you see this type of behavior? I usually remove the blank pages from the capture as it has little to do with app. server load.

--------------------
A problem is a difference between what is perceived and what is desired, that
we want to reduce
(Dewey 1933)


Post Extras: Print Post   Remind Me!   Notify Moderator  
priyaganesh
Newbie


Reged: 09/10/10
Posts: 8
Re: Reg: Microstrategy Application [Re: drazle]
      #669464 - 04/26/11 11:24 PM

Hi Drazle,

it is a Microstrategy application. They use Microstrategy tool for front end. basically on analysis i found that a session state gets differs no sunch session states are captured in our script to handle it . i dont find any sessionstate parameter under the cgi parameter tree. what can i do? how can i handle that session state? whether tool is not supporting the application?


Post Extras: Print Post   Remind Me!   Notify Moderator  
drazle
Active Member


Reged: 11/30/00
Posts: 829
Loc: Michigan, USA
Re: Reg: Microstrategy Application [Re: priyaganesh]
      #669693 - 04/28/11 07:26 AM

The only suggestion I have is to use a proxy capture (Fiddler) and capture your own manual interactions. Compare the parameters it is showing to what QALoad captures and see if QALoad is missing anything.

I've not heard of a session variable that cannot be captured, but I'm sure there are things that I haven't encountered (I've not worked with Microstrategy app before). If it is a session var that is stored on the server, then it must be associated to either a cookie or variable the client stores, or the client IP. If it is the IP then it should work fine for 1 user at least and then that may be that you need to use IP spoofing.

Otherwise... I have no idea and my guess is that it is using some kind of customized protocol (I'm thinking of Siebel here) that would require specific support from the tool. It would seem the MicroFocus could give you more guidance on this.

You could also try posting to the main performance testing forum to see if anyone has worked with Microstrategy app before, they may be able to help.

As I re-read the thread I realize that you are saying it is using a Microstrategy client, is this accurate? If so then it may very well be that the tool would need to specifically support the app's customized protocol. Again, it would seem that if this is the case, then MicroFocus would be able to say whether or not it is supported and give you more guidance about how to implement.

--------------------
A problem is a difference between what is perceived and what is desired, that
we want to reduce
(Dewey 1933)


Post Extras: Print Post   Remind Me!   Notify Moderator  
shippee
Member


Reged: 02/23/09
Posts: 25
Re: Reg: Microstrategy Application [Re: drazle]
      #681413 - 08/06/11 09:38 AM

Is there a simple primer on using Fiddler with QALoad? Simply launching Fiddler before or after QALoad does not work for me - I'm guessing some additional configuration(s) might be in order, e.g., port numbers or something?

Thanks in advance,

steve


Post Extras: Print Post   Remind Me!   Notify Moderator  
Pages: 1



Extra information
0 registered and 1 anonymous users are browsing this forum.

Moderator:  AJ, DSquared 

Print Topic

Forum Permissions
      You cannot start new topics
      You cannot reply to topics
      HTML is disabled
      UBBCode is enabled

Rating:
Topic views: 5250

Rate this topic

Jump to

Contact Us | Privacy statement SQAForums

Powered by UBB.threads™ 6.5.5