The online community for software testing & quality assurance professionals
 
 
Calendar   Today's Topics
Sponsors:




Lost Password?

Home
BetaSoft
Blogs
Jobs
Training
News
Links
Downloads



Testing Tools >> Micro Focus/Compuware QALoad

Pages: 1
gtiu
Newbie


Reged: 11/04/09
Posts: 1
JSON response content missing
      #600189 - 11/05/09 03:04 PM

I'm trying to record a WWW test script but I noticed that the recording seems to be missing the content for some of my HTTP

requests. Looking at the vistree, I can see the response header specifying 4272 bytes for the response (which is correct) but the

content below it is missing (it lists the sub-request header and sub-request contents below it instead).

The response content from the vistree looks like:

------------------------------

.====================== Main Request 22 ======================
http://testbox:8080/<...>/dataloader?par=true
(this block of text is not part of the page source)
.================================================================
HTTP/1.1 200 OK
Server: Apache-Coyote/1.1
Content-Type: application/json
Content-Length: 4272
Date: Thu, 05 Nov 2009 00:46:42 GMT





.====================== Additional SubRequest 22.47 ======================
http://testbox:8080/<...>/min.js
(this block of text is not part of the page source)
.================================================================
HTTP/1.1 200 OK
Server: Apache-Coyote/1.1
Cache-Control: max-age=3600
Last-Modified: Tue, 27 Oct 2009 05:07:50 GMT
Content-Type: text/javascript
Content-Length: 138037
Date: Thu, 05 Nov 2009 00:46:42 GMT
Expires: : Thu, 05 Nov 2009 00:46:42 GMT

<content for min.js...>

------------------------------

As part of test validation, I intended to add content checking but neither the vistree nor the .cap file seem to have any record

of the main request's content. When I ran a packet sniffer at the same time, it shows that the content is actually being

transmitted but QALoad is not showing it anywhere.

I tried adding a global prohibited content check for a specific string that should be in the missing content, then ran a test but

the test failed to detect any response containing that string.


Post Extras: Print Post   Remind Me!   Notify Moderator  
jmeuh
Newbie


Reged: 02/06/07
Posts: 14
Re: JSON response content missing [Re: gtiu]
      #640751 - 09/01/10 08:50 AM

You should add content type application/json to handled ones to have json content saved onto cap file. This should allow you to perform content check on it.
See Convert Options


Post Extras: Print Post   Remind Me!   Notify Moderator  
Pages: 1



Extra information
0 registered and 2 anonymous users are browsing this forum.

Moderator:  AJ, DSquared 

Print Topic

Forum Permissions
      You cannot start new topics
      You cannot reply to topics
      HTML is disabled
      UBBCode is enabled

Rating:
Topic views: 2843

Rate this topic

Jump to

Contact Us | Privacy statement SQAForums

Powered by UBB.threads™ 6.5.5