The online community for software testing & quality assurance professionals
 
 
Calendar   Today's Topics
Sponsors:




Lost Password?

Home
BetaSoft
Blogs
Jobs
Training
News
Links
Downloads



Testing Tools >> IBM/Rational Robot

Pages: 1
QATester1982
Newbie


Reged: 01/06/09
Posts: 23
Can we use development ID?
      #579077 - 07/09/09 11:30 PM

During recording Robot generates unique ID's for all the objects. Instead can we use object's development ID? Is there any way of using development ID in Rational Robot? Is it feasible to use the development ID?

Post Extras: Print Post   Remind Me!   Notify Moderator  
507073
Junior Member


Reged: 08/27/04
Posts: 161
Loc: Rochester, NY
Re: Can we use development ID? [Re: QATester1982]
      #579177 - 07/10/09 07:17 AM

QATester1982,
robot doesn't generate an Id. If the recognition string is "ID=5000" thats a Windows ID number that you can see in other spy type programs.
Whether the ID number is stable from run to run or build to build depends on your application.

Use the inspector or the vp gui to see if you can find the property you want if it's not in there then you can't use that data directly in Robot. Name may be the property you want. It's not available in all guis though. I think it's only in vb, powerbilder & .net but there may be other

Phil.


Post Extras: Print Post   Remind Me!   Notify Moderator  
QATester1982
Newbie


Reged: 01/06/09
Posts: 23
Re: Can we use development ID? [Re: 507073]
      #579387 - 07/13/09 02:26 AM

Hello Phil,

This is the piece of code that robot generates for application during recording. My product developement team says that the HTMLId that is being generated is not the development ID,it is being generated by robot internally. But as you saying robot doesn't generate an ID, i am confused how these ID's are getting generated during recording? Instead of these ID development team asked me to use development ID. Is there any way of doing this?

HTMLclick, "Type=HTML;HTMLId=uwt_21;VisualText=Infirmary", "Coords=39,7"
HTMLClick, "Type=HTML;HTMLId=uwt_21;VisualText=Infirmary", "Coords=39,7"
HTMLClick, "Type=HTML;HTMLId=uwt_21_1;VisualText=Definition", "Coords=44,3"


Post Extras: Print Post   Remind Me!   Notify Moderator  
507073
Junior Member


Reged: 08/27/04
Posts: 161
Loc: Rochester, NY
Re: Can we use development ID? [Re: QATester1982]
      #579441 - 07/13/09 06:13 AM

QATester1982,
sorry, I thought you meant the ID property not the HTMLID. I expect if you look at the DOM for your page in some other application (like Microsoft Internet Explorer Developer Toolbar ) you'd get the same HTML ID property.

If the name property is not what your looking for I expect that you wont be able to easily ID the object you want.
What toolkit does the page use?

Phil


Post Extras: Print Post   Remind Me!   Notify Moderator  
QATester1982
Newbie


Reged: 01/06/09
Posts: 23
Re: Can we use development ID? [Re: 507073]
      #580025 - 07/15/09 06:08 AM

We are using Infragistic controls. I am facing this problem with Tree control, since it is dynamic control it always generates different ID. Can we use some other property to identify the object?

Post Extras: Print Post   Remind Me!   Notify Moderator  
507073
Junior Member


Reged: 08/27/04
Posts: 161
Loc: Rochester, NY
Re: Can we use development ID? [Re: QATester1982]
      #580102 - 07/15/09 09:26 AM

QATester1982,
I don't belive IBM has ever offered built in support for Infragistic controls. If you need it you could talk to appoint about their proxy controls.

Phil.


Post Extras: Print Post   Remind Me!   Notify Moderator  
Ciege
Advanced Member


Reged: 02/27/02
Posts: 593
Loc: Scottsdale, AZ, USA
Re: Can we use development ID? [Re: 507073]
      #580106 - 07/15/09 09:30 AM

You are correct Phil. I've had to use the AppPoint proxy with Robot in the past (when I was still using Robot). They were reasonably priced (if you swallow the pill that you have to pay for a 3rd party solution) and seemed to work pretty well.

--------------------
If this or any response has helped you, please reply to the thread stating that it worked so other people with a similar issue will know how you fixed your issue!

Ciege...


Post Extras: Print Post   Remind Me!   Notify Moderator  
Pages: 1



Extra information
0 registered and 8 anonymous users are browsing this forum.

Moderator:  AJ, RSBarber 

Print Topic

Forum Permissions
      You cannot start new topics
      You cannot reply to topics
      HTML is disabled
      UBBCode is enabled

Rating:
Topic views: 1898

Rate this topic

Jump to

Contact Us | Privacy statement SQAForums

Powered by UBB.threads™ 6.5.5