The online community for software testing & quality assurance professionals
 
 
Calendar   Today's Topics
Sponsors:




Lost Password?

Home
BetaSoft
Blogs
Jobs
Training
News
Links
Downloads



Testing Tools >> IBM/Rational Visual Test

Pages: 1
Shekharr
Newbie


Reged: 07/08/08
Posts: 3
Visual Test on Vista OS
      #498014 - 07/08/08 06:00 AM

Hi Experts,



This is regarding running Visual Test scripts on Vista environment.
Thought about throwing this issue in SQAforum, but while going through threads on forum
found you guys can help me out.



To start off while running VT scripts on vista OS observed that to access controls on application here we have to hold CTRL key continiously. Suspected that there might be security issue which OS is not allowing VT to talk with application, So I changed all the system security preveliges(UAC).


After doing this also observed the same CTRL key issue. After analysing each .api and .inc file, found that scripts runs fine if we pass the parameters directly into the main script rather than delcaring them in .inc file and calling in main script.



Now the major issue is we have huge number of automated VT scripts which has to be run on vista OS.Modifying each VT script consumes large amount of manhour. Expecting some suggestions in this regard.



Illustrating this issue with example:



Below mentioned code runs without any issue where no .inc file are associated.



'*** Start-up code
if wFndWnd("- Notepad", FW_PART OR FW_ALL OR FW_FOCUS) = 0 then
print "Notepad window not found."
print "Attempting to run Notepad."

if run("notepad.exe") <> 0 then
print "Unable to run Notepad."
print "Tests stopped."
stop
endif
endif

'*** Test
wMenuSelect("File\Open")
wEditSetText("File name:","bootlog.txt")
wButtonClick("Open")

'*** Clean-up code
if wFndWnd("- Notepad", FW_PART OR FW_ALL OR FW_FOCUS) then
wMenuSelect("File\Exit")
endif

print "Test completed on "+DATETIME$

END



Now if the same code written in below mentioned fashion VT script needs holding of CTRL key to do the action.


'$include "notemain.inc"
'$include "noteutil.inc"

'*** Program begins
StartTest

'*** Test wMenuSelect(MNU_FILE_OPEN)
wEditSetText(LBL_FILENAME,"bootlog.txt")
wButtonClick(BTN_OPEN)

StopTest

END


'$include "notemain.inc" contains constant declaration.
'*** Constant decls
CONST CAP_MAINWIN$ = "- Notepad"
CONST FW_MYCRITERIA& = FW_PART OR FW_ALL OR FW_FOCUS
CONST FN_TESTAPP$ = "notepad.exe"
CONST MNU_FILE_OPEN$ = "File\Open..."
CONST MNU_FILE_EXIT$ = "File\Exit"
CONST LBL_FILENAME$ = "File name:" CONST BTN_OPEN$ = "Open"


'$include "noteutil.inc" file contains below code

*** Subroutines

'*** Start-up code
sub StartTest
if wFndWnd(CAP_MAINWIN, FW_MYCRITERIA) = 0 then
print FN_TESTAPP+" window not found."
print "Attempting to run "+FN_TESTAPP

if run(FN_TESTAPP) = 0 then
print "Unable to run "+FN_TESTAPP
print "Tests stopped."
stop
endif
endif
end sub 'StartTest



Eagerly waiting for your valuable help/suggestions in this regard.



Thanks in Advance,
Shekhar


Post Extras: Print Post   Remind Me!   Notify Moderator  
tmpalaniselvam
Veteran


Reged: 09/18/01
Posts: 2511
Loc: Bangalore,India
Re: Visual Test on Vista OS [Re: Shekharr]
      #498061 - 07/08/08 07:15 AM

Shekhar,
I think, you didn't get your problem correctly. I hope that Vista architecture is different from other windows OS.

Very very few people are using Visual Test.

--------------------
Thanks & Regards,
Palani.
http://tips-testing.blogspot.com/index.html
Quote: Dont hesitate to initiate!


Post Extras: Print Post   Remind Me!   Notify Moderator  
Shekharr
Newbie


Reged: 07/08/08
Posts: 3
Re: Visual Test on Vista OS [Re: tmpalaniselvam]
      #498241 - 07/08/08 09:08 PM

Palani,
Thanks for reply.
The problem is Iam able to run VT scripts without using any include file but cant run with include file. Looking for an alternative solution.

Thanks,
Shekhar


Post Extras: Print Post   Remind Me!   Notify Moderator  
tmpalaniselvam
Veteran


Reged: 09/18/01
Posts: 2511
Loc: Bangalore,India
Re: Visual Test on Vista OS [Re: Shekharr]
      #498294 - 07/09/08 12:28 AM

I'm unable to guess the problem correctly. I am wondering how it is working on Vista.

--------------------
Thanks & Regards,
Palani.
http://tips-testing.blogspot.com/index.html
Quote: Dont hesitate to initiate!


Post Extras: Print Post   Remind Me!   Notify Moderator  
Shekharr
Newbie


Reged: 07/08/08
Posts: 3
Re: Visual Test on Vista OS [Re: tmpalaniselvam]
      #498746 - 07/10/08 04:28 AM

Palani,

The fact is VT scripts are running on windows vista OS. Now I am not able to move ahead in this regard. As you said there are very few VT users thats the reason no support, contacted few VT users but now they are moved over to Robot. Does sending clip will be helpfull for you to know the problem and suggest regarding the same? Please let me know.

Thanks,
Shekhar


Post Extras: Print Post   Remind Me!   Notify Moderator  
tmpalaniselvam
Veteran


Reged: 09/18/01
Posts: 2511
Loc: Bangalore,India
Re: Visual Test on Vista OS [Re: Shekharr]
      #499072 - 07/11/08 03:00 AM

Product updates were stopped/ended 8 yrs ago. You can't get the Vendor support.

For your pbm, I think few DLLs may not work in the expected way or any conflict with advanced technologies..

--------------------
Thanks & Regards,
Palani.
http://tips-testing.blogspot.com/index.html
Quote: Dont hesitate to initiate!


Post Extras: Print Post   Remind Me!   Notify Moderator  
cvieira
Member


Reged: 08/05/05
Posts: 32
Re: Visual Test on Vista OS [Re: tmpalaniselvam]
      #516431 - 09/11/08 06:29 PM

Hi Shekharr.

In my shop we have dozens of VT programs running on Vista. You've already leaped the main hurdle by modifying the UAC setting.

I can't think of any reason you should be having problems with include files. Our VT programs typically use more than a dozen .inc files without issue.

Ours are all written as standalone .pc6 files with their own UI. Are you maybe running your scripts with Scenario Manager?

--------------------
--- Hacksaw


Post Extras: Print Post   Remind Me!   Notify Moderator  
April_20
Junior Member


Reged: 02/24/06
Posts: 195
Loc: Princeton, NJ
Re: Visual Test on Vista OS [Re: cvieira]
      #535535 - 12/01/08 02:45 PM

I think you will get compilation error, if include same .inc file more than once. Use precompiler directives DEFINE and IFNOTDEFINED to solve this problem.

Post Extras: Print Post   Remind Me!   Notify Moderator  
Pages: 1



Extra information
0 registered and 0 anonymous users are browsing this forum.

Moderator:  AJ 

Print Topic

Forum Permissions
      You cannot start new topics
      You cannot reply to topics
      HTML is disabled
      UBBCode is enabled

Rating:
Topic views: 8093

Rate this topic

Jump to

Contact Us | Privacy statement SQAForums

Powered by UBB.threads™ 6.5.5