The online community for software testing & quality assurance professionals
 
 
Calendar   Today's Topics
Sponsors:




Lost Password?

Home
BetaSoft
Blogs
Jobs
Training
News
Links
Downloads



Testing Tools >> IBM/Rational Visual Test

Pages: 1
davepeterson
Newbie


Reged: 04/03/08
Posts: 1
Clicking Links in IE7
      #472474 - 04/03/08 08:34 AM

Hi,

I have a large number of scripts written for our web application, and these scripts use the WebLinkClick function regularly. This works fine in Internet Explorer 6 but for whatever reason in IE7 it fails with the message "Specified Link Does Not Exist".

It's using the text of the link so ordinals are not an issue, I've also used WebLinkExists immediately before the click and it comes back true. It definitely has something to do with IE7, I'm just wondering if any one else has encountered this or knows of a workaround.

Thanks in Advance

--------------------
Dave Peterson
Quality Assurance Automation Specialist
Emerging Information Systems Inc.


Post Extras: Print Post   Remind Me!   Notify Moderator  
tmpalaniselvam
Veteran


Reged: 09/18/01
Posts: 2511
Loc: Bangalore,India
Re: Clicking Links in IE7 [Re: davepeterson]
      #472996 - 04/05/08 03:44 AM

I guess that IE7 and IE6 has huge difference in terms of usage and look. It may work, if you change the registry similar to IE6..

--------------------
Thanks & Regards,
Palani.
http://tips-testing.blogspot.com/index.html
Quote: Dont hesitate to initiate!


Post Extras: Print Post   Remind Me!   Notify Moderator  
MPC2010
Newbie


Reged: 10/03/07
Posts: 10
Re: Clicking Links in IE7 [Re: davepeterson]
      #548278 - 02/05/09 09:05 PM

I am also facing the same problem. Actually when the focus of window changes the script won't work

Post Extras: Print Post   Remind Me!   Notify Moderator  
ms6073
Member


Reged: 11/27/01
Posts: 60
Loc: Houston, Tx, USA
Re: Clicking Links in IE7 [Re: MPC2010]
      #550431 - 02/13/09 11:00 AM

With tabbed browsing, VT web functionality probably has issues so and most likely you will need to work with the IE Document Object Model. Simple test, open your webpage in IE and launch VTs Winfo.pc6, select the Web tab and drag the crosshair over the link in question on your page in IE. If the Web tab does not populate with information about the link, then VT's web fucntions are not going to be very useful. In this case you will probably have to work through the IE DOM document collections to make sure you have the correct link. I have not coded this in VT but below is some VBScript that I have used to manipul;ate websites in IE - if you research the IE Dom you should be able to port this VBS code to VT:

Set appIE = CreateObject("InternetExplorer.Application")

With appIE
.Visible = 1
.Navigate "http://google.com"
Do Until .readyState = 4 : WScript.Sleep 50 : Loop

' are we at the correct web page?
If Instr(LCase(.Document.Title), "google") <> 0 Then
Set ElementCol = .Document.getElementsByTagName("input")
For Each txtInput in ElementCol
WScript.Echo txtInput.Name
Next
End If
End With

--------------------
Michael - Armageddon was yesterday, today we have a serious problem!


Post Extras: Print Post   Remind Me!   Notify Moderator  
Pages: 1



Extra information
0 registered and 1 anonymous users are browsing this forum.

Moderator:  AJ 

Print Topic

Forum Permissions
      You cannot start new topics
      You cannot reply to topics
      HTML is disabled
      UBBCode is enabled

Rating:
Topic views: 4977

Rate this topic

Jump to

Contact Us | Privacy statement SQAForums

Powered by UBB.threads™ 6.5.5