The online community for software testing & quality assurance professionals
 
 
Calendar   Today's Topics
Sponsors:




Lost Password?

Home
BetaSoft
Blogs
Jobs
Training
News
Links
Downloads



Testing Tools >> HP / Mercury WinRunner

Pages: 1
ds_sorney
Newbie


Reged: 01/08/08
Posts: 3
winrunner 9/servlets/objects gone
      #446606 - 01/08/08 08:11 AM

Anyone ever run into trouble with obj's not showing up on a webpage (obviously)?

Here's what's happening:
1. Using WR9.2, Web test and Java addin's loaded.
2. AUT is a simple webpage with a date calendar and a listbox that is running with a javascript servlet. Date calendar is a yahoo widget (may be the culprit, not sure).
3. Gui SPY can't see anything other than the html_frame, can learn the listbox, but then can't see it once it has been learned.

So far I have tried messing with the GUI Config to add some more properties, but no luck. I've tried different add-in combos, have wild carded the GUI map, still no luck. I'm running out of tricks.
Any other thing I may be missing?
Thanks

--------------------
<a href="http://www.linkedin.com/in/sorney" ><img src="http://www.linkedin.com/img/webpromo/btn_viewmy_160x33.gif" width="160" height="33" border="0" alt="View Dave Sorenson's profile on LinkedIn"></a>


Post Extras: Print Post   Remind Me!   Notify Moderator  
Tony Davis
Veteran


Reged: 03/23/00
Posts: 3082
Loc: Orange County, CA
Re: winrunner 9/servlets/objects gone [Re: ds_sorney]
      #446625 - 01/08/08 09:02 AM

Not a solution, but something more to check -


Have you ensured the version of Java you have installed on the client is supported by the plug in? WinRunner is a little behind what is the current released JRE from what I remember

--------------------
Insanity: doing the same thing over and over again and expecting different results


Post Extras: Print Post   Remind Me!   Notify Moderator  
ds_sorney
Newbie


Reged: 01/08/08
Posts: 3
Re: winrunner 9/servlets/objects gone [Re: Tony Davis]
      #446633 - 01/08/08 09:10 AM

Java...yup, it's supported. I do java scripts on this bad boy as well. I'm beginning to think it has something to do with the Yahoo YUI widget class the more I look into it. But still haven't figured anything concrete out.

--------------------
<a href="http://www.linkedin.com/in/sorney" ><img src="http://www.linkedin.com/img/webpromo/btn_viewmy_160x33.gif" width="160" height="33" border="0" alt="View Dave Sorenson's profile on LinkedIn"></a>


Post Extras: Print Post   Remind Me!   Notify Moderator  
Tony Davis
Veteran


Reged: 03/23/00
Posts: 3082
Loc: Orange County, CA
Re: winrunner 9/servlets/objects gone [Re: ds_sorney]
      #446663 - 01/08/08 09:48 AM

Yahoo widget is evil incarnate when it comes to scripting. That plug-in package of hot burning evil has put my project behind so many times when I haven't noticed someone installing it on my test systems.

--------------------
Insanity: doing the same thing over and over again and expecting different results


Post Extras: Print Post   Remind Me!   Notify Moderator  
ds_sorney
Newbie


Reged: 01/08/08
Posts: 3
Re: winrunner 9/servlets/objects gone [Re: Tony Davis]
      #446667 - 01/08/08 09:51 AM

Interesting. Perhaps I will travel down that path for a bit then. Thanks for the insight.

--------------------
<a href="http://www.linkedin.com/in/sorney" ><img src="http://www.linkedin.com/img/webpromo/btn_viewmy_160x33.gif" width="160" height="33" border="0" alt="View Dave Sorenson's profile on LinkedIn"></a>


Post Extras: Print Post   Remind Me!   Notify Moderator  
dotee
Newbie


Reged: 11/04/08
Posts: 1
Re: winrunner 9/servlets/objects gone [Re: ds_sorney]
      #529010 - 11/04/08 02:00 AM

Has anyone worked out how to get WinRunner to 'see' Yahoo widgets yet? I've just hit this and it's blocking me completely!

Post Extras: Print Post   Remind Me!   Notify Moderator  
Pages: 1



Extra information
0 registered and 9 anonymous users are browsing this forum.

Moderator:  Peter Ruscoe, bpolitzer 

Print Topic

Forum Permissions
      You cannot start new topics
      You cannot reply to topics
      HTML is disabled
      UBBCode is enabled

Rating:
Topic views: 2621

Rate this topic

Jump to

Contact Us | Privacy statement SQAForums

Powered by UBB.threads™ 6.5.5