The online community for software testing & quality assurance professionals
 
 
Calendar   Today's Topics
Sponsors:




Lost Password?

Home
BetaSoft
Blogs
Jobs
Training
News
Links
Downloads



Testing Tools >> Application Center Test

Pages: 1
Rajeev Vaidya
Junior Member


Reged: 01/27/04
Posts: 2
Loc: Ahmedabad, India
Microsoft ACT: Problem facing for Proxy Settings
      #322345 - 01/27/04 06:05 AM

I am facing following problems while working with proxy settings.

Case:

1. In Project properties/General Tab, uncheck "Use a proxy server".

2. From new test wizard dialog box, select "option Record a new test"
and click on "Start recording". Microsoft ACT opens internet explorer.

In Internet Option/Local Area Network settings, Proxy server shows always checked with following
address details.

Address: localhost
Port: 81

3. Go to control panel/Internet Options/LAN settings. Uncheck "Use a proxy server
for your LAN". Save Internet Options.

4. Repeat steps 1 and 2. It shows the same result as written in step 2.

Configurations used:

Microsoft ACT version 1.0.527.0
(version comes with microsoft Development Environment 2002 version 7.0.9466)

OS: Microsoft Windows 2000 5.00.2195
Service Pack 4
Intel(R) Pentium
(R)4 CPU 1.60GHz
AT/AT COMPATIBLE
261,424 KB RAM

No proxy server installed on PC.

Kindly help me out in solving this problem.

Thanks,
Rajeev Vaidya


Post Extras: Print Post   Remind Me!   Notify Moderator  
Viveku
Newbie


Reged: 12/13/06
Posts: 21
Re: Microsoft ACT: Problem facing for Proxy Settings [Re: Rajeev Vaidya]
      #346925 - 12/13/06 01:43 AM

I too am facing similar problem but the ultimate issue is different.
When I record ACT script, I am able to connect to my web app but it immediately gives me "Session has timed out, reauthenticate ..."
My ASP app is on W2K3 server with IIS 6.0 and Integrated Auth Mode.
The issue is, if i make the same proxy setting manually (to browser on machine) as what ACT does during recording (proxy localhost and port 8181), i am able to connect without timeout to my app outside ACT.
Not able to get any help on the net and MS technet. Any help would be greatly appreciated! Thanks!


Post Extras: Print Post   Remind Me!   Notify Moderator  
Ian
Member


Reged: 09/13/01
Posts: 332
Loc: Sunnyvale, CA, Santa Clara
Re: Microsoft ACT: Problem facing for Proxy Settings [Re: Rajeev Vaidya]
      #348083 - 12/18/06 08:54 PM

I don't know if this helps but the local proxy that you see is the ACT recording proxy. ACT puts the http traffic thru its own proxy when in record mode, on the localhost, and then extracts the requests etc. from that. ACT cannot record thru a 'real' proxy. During playback however, ACT can go via a proxy and that is what you can set in the options of ACT.

Hope this helps.

--------------------
Regards

Ian
http://sqa.net


Post Extras: Print Post   Remind Me!   Notify Moderator  
Viveku
Newbie


Reged: 12/13/06
Posts: 21
Re: Microsoft ACT: Problem facing for Proxy Settings [Re: Ian]
      #349266 - 12/25/06 09:17 PM

Unfortunately the problem is not solved yet!
Thanks anyway!


Post Extras: Print Post   Remind Me!   Notify Moderator  
Pages: 1



Extra information
0 registered and 1 anonymous users are browsing this forum.

Moderator:  AJ 

Print Topic

Forum Permissions
      You cannot start new topics
      You cannot reply to topics
      HTML is disabled
      UBBCode is enabled

Rating:
Topic views: 5514

Rate this topic

Jump to

Contact Us | Privacy statement SQAForums

Powered by UBB.threads™ 6.5.5