SPONSORS:






User Tag List

Thanks Thanks:  0
Likes Likes:  0
Dislikes Dislikes:  0
Results 1 to 4 of 4

Thread: Throughput !!!!

  1. #1
    Member
    Join Date
    Apr 2007
    Posts
    83
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Total Downloaded
    0

    Throughput !!!!

    Hi,

    We are using Webload Open Source 8.1.0.118.0

    We have used step incremental load to load test the machine for the number of users that it can handle

    Load generator machine has sufficient configuration to handle 100 users atleast

    Our application server configuration is very good --> IBM websphere, Intel Xeon 2.69Ghz, 4.5 GB RAM

    Database server configuration is somewhat similar.

    However, after running the load, the throughput increases incrementally till about 15 users and then slips to 0. Same can be said about Hits Per Second. Since both are decreasing to zero, its difficult to conclude that there is a problem with the Load Generator. We are totally confused by this behavior

    We tried running using multi-threading, however, after say 12 users join in, "Load Generator Disconnected" damnnnnn!!!

    Any help on this would be really appreciated!!!

    Thanks,
    Tushar

  2. #2
    Senior Member
    Join Date
    Oct 2006
    Posts
    164
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Total Downloaded
    0

    Re: Throughput !!!!

    While running the test, you might have enabled monitors in your servers. What do they say?

    Also enable monitor in your loadgenerator also. Then you will come to some conclusion.
    Morty

  3. #3
    Member
    Join Date
    Apr 2007
    Posts
    83
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Total Downloaded
    0

    Re: Throughput !!!!

    The problem was due to sessions on the server, they were just too many!

    However, we are still confused on why the hits per second was reduced to zero, since its the load generator that creates these hits

    Monitors on the loadgenerator were all fine: CPU, RAM all with-in limits

  4. #4
    Senior Member
    Join Date
    Oct 2006
    Posts
    164
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Total Downloaded
    0

    Re: Throughput !!!!

    It would be like this...
    all the virtual users might have sent the request to the server and those requests might have been in the queue.

    In webload the timeout period is 900 seconds. It will wait till 900 seconds before mark it as timeout and send the request again.
    Morty

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Search Engine Optimisation provided by DragonByte SEO v2.0.36 (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Resources saved on this page: MySQL 11.54%
vBulletin Optimisation provided by vB Optimise v2.6.4 (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging v3.2.8 (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
vBNominate (Lite) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Feedback Buttons provided by Advanced Post Thanks / Like (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Username Changing provided by Username Change (Free) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
BetaSoft Inc.
Digital Point modules: Sphinx-based search
All times are GMT -8. The time now is 02:36 AM.

Copyright BetaSoft Inc.