SPONSORS:






User Tag List

Thanks Thanks:  0
Likes Likes:  0
Dislikes Dislikes:  0
Results 1 to 3 of 3
  1. #1
    Junior Member
    Join Date
    Jul 2005
    Location
    Israel
    Posts
    13
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Total Downloaded
    0

    Can\'t compile script with subroutines

    In definitions section I have
    </font><blockquote><font size="1" face="Verdana, Arial, Helvetica">code:</font><hr /><pre style="font-size:x-small; font-family: monospace;"> INTEGER RC </pre><hr /></blockquote><font size="2" face="Verdana, Arial, Helvetica">And in Code section I have
    </font><blockquote><font size="1" face="Verdana, Arial, Helvetica">code:</font><hr /><pre style="font-size:x-small; font-family: monospace;"> SUBROUTINE CheckReturningCode [RC]
    IF (MY_RESP_DEBUG = &quot;true&quot THEN
    REPORT &quot;MY_RC = &quot;,RC
    ENDIF
    IF (RC &gt; 399) THEN
    REPORT &quot;RETURNING CODE is &quot;, RC
    FAIL TEST-CASE
    ENDIF
    RETURN
    END SUBROUTINE </pre><hr /></blockquote><font size="2" face="Verdana, Arial, Helvetica">But the script can't be compiled.

    This is the errors I get:
    SUBROUTINE CheckReturningCode [RC]
    ***********************
    XX-XXX.HTP(48) : error (invnam), Invalid Name

    RETURN
    ******
    XX-XXX.HTP(56) : error (invreturn), Invalid placement of RETURN outside a subroutine

    END SUBROUTINE
    XX-XXX.HTP(57) : error (invendsub), Invalid placement of END SUBROUTINE command
    scl: info (endnoobj), XX-XXX.HTP Completed with 3 Diagnostics - Object Deleted
    <font size="2" face="Verdana, Arial, Helvetica">Does someone have any idea what is wrong?

    Regards,
    Uri.

  2. #2
    Senior Member
    Join Date
    Oct 2001
    Location
    Lakes Region, NH, USA
    Posts
    318
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Total Downloaded
    0

    Re: Can\'t compile script with subroutines

    Fix your first error and the others should disappear.

    Your SUBROUTINE name is not a valid OpenSTA dataname.
    Daniel Sutcliffe
    OpenSTA part-time Caretaker - http://OpenSTA.org/

  3. #3
    Junior Member
    Join Date
    Jul 2005
    Location
    Israel
    Posts
    13
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Total Downloaded
    0

    Re: Can\'t compile script with subroutines

    Thanks,
    I cut the subroutine name and it was OK.

    Regards,
    Uri.

    Originally posted by dansut:
    Fix your first error and the others should disappear.

    Your SUBROUTINE name is not a valid OpenSTA dataname.
    <font size="2" face="Verdana, Arial, Helvetica">

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Search Engine Optimisation provided by DragonByte SEO v2.0.36 (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Resources saved on this page: MySQL 11.11%
vBulletin Optimisation provided by vB Optimise v2.6.4 (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging v3.2.8 (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
vBNominate (Lite) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Feedback Buttons provided by Advanced Post Thanks / Like (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Username Changing provided by Username Change (Free) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
BetaSoft Inc.
Digital Point modules: Sphinx-based search
All times are GMT -8. The time now is 01:12 PM.

Copyright BetaSoft Inc.