SPONSORS:






User Tag List

Thanks Thanks:  0
Likes Likes:  0
Dislikes Dislikes:  0
Results 1 to 2 of 2
  1. #1
    Member
    Join Date
    Sep 2007
    Location
    Denver, Colorado
    Posts
    41
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Total Downloaded
    0

    v6.0 References & .Net References for Infragistics

    This has to do with the dreaded Infragistics controls not working correctly in TestPartner 6.0. My application is a .Net app running on Fat Client.

    I have a TP Project that contains 1 Test Script that executes code in 14 Shared Modules each containing multiple functions. The Reference list (Tools / References) appears to be unique to each Asset, the Test Script itself and each Shared Module. Is this true? [img]/images/graemlins/shocked.gif[/img] Do I have to set the Reference list in each Shared Module in the Project or is there a setting for the entire Project?

    In the References I have checked the following:
    TestPartnerInterop_Infragistics2_Win_UltraWinTree_ v6.3
    TestPartnerInterop_Infragistics2_Win_UltraWinGrid_ v6.3 TestPartnerInterop_Infragistics2_Win_UltraWinToolb ars_v6.3

    Also in the Available Reference list exists these other Infragistics lines that I DO NOT have checked:
    Infragistics UltraTree Control class library – Release Version
    Infragistics UltraGrid Control class library – Release Version
    Infragistics UltraToolbars Control class library – Release Version
    Plus a lot of others. Do I need to check these as well?

    Another available reference is TestPartner .NET v2.0 Support. Since version 6.3 of Infragistics relies on .Net v2, should this be checked?

    There are also some old versions of Infragistics in the Available Reference list (not checked) that no longer exist on the PC, can I (should I) delete them out of the Available References list?

    I’m unclear as to the differences between References and .Net References. I know that .Net References are for Intellisense, but is that the only reason for them? I’ve gone through and “Updated” all the .Net References for the Infragistics controls we use (UltraWinTree, UltraWinGrid, UltraWinToolbars, UltraWinTabControl and UltraWinMaskedEdit – version 6.3). There’s an Identify button on the .Net Reference, do I need to Identify all UltraWin objects? [img]/images/graemlins/confused.gif[/img]

    I also have some Visual Tests in this project and the References and .Net References are not available for these Visual Tests, so I’m assuming that they are not needed? My Infragistics controls are not working in Visual Tests either, but if I can get them working in Test Scripts then I won’t need the Visual Tests.
    Using TestPartner 6.0 Build 462
    Test Scripts & Visual Tests

  2. #2
    Member
    Join Date
    Sep 2007
    Location
    Denver, Colorado
    Posts
    41
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Total Downloaded
    0

    Re: v6.0 References & .Net References for Infragistics

    I discovered some answers, and finally got my script working. This is what I've found...

    You do have to set the References and .NET References for each TP Asset, Test Scripts, Modules and Shared Modules. I suppose it's done this way because not all Assets will need the references.
    The Infragistics References that I indicated above that were NOT checked did not have to be checked to get my script working.
    I did have to remove the old versions of Infragistics that got set in the References, but it only happened when I went in manually to c:\Depends and deleted them from there. One of our developers said that having multiple versions of Infragistics on your computer would cause confusion, so I uninstalled all of Infragistics, and then had to manually uninstall the older versions. Then I removed the references that were stored in c:\Depends. Then when I installed my application it installed only the Infragistics dlls that were needed.
    I then used the Identify button on the .NET Reference dialog box, clicked on my Infragistics tree control, and it correctly identified it as version 6.3 and added the correct dll to the .NET Reference list, and updated the intellisense for me.
    I had 15 TP Assets to go through and do this; I finally got my app working, even with the dreaded Infragistics controls.

    The only thing I'm not really sure of now is what is the c:\Depends used for? It didn't seem to make a difference to the running of TP when I cleared it out.

    Thanks to everyone who read this and tried to help me.
    Using TestPartner 6.0 Build 462
    Test Scripts & Visual Tests

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Search Engine Optimisation provided by DragonByte SEO v2.0.36 (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Resources saved on this page: MySQL 12.50%
vBulletin Optimisation provided by vB Optimise v2.6.4 (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging v3.2.8 (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
vBNominate (Lite) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Feedback Buttons provided by Advanced Post Thanks / Like (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Username Changing provided by Username Change (Free) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
BetaSoft Inc.
Digital Point modules: Sphinx-based search
All times are GMT -8. The time now is 02:32 AM.

Copyright BetaSoft Inc.