I am currently using lots of bitmap checks in my project, to check whether a graph, which is being updated in various ways, is displaying correctly. I have reused lots of the checks, as different actions on the GUI can restore the graph to the same state. For instance, I have one check for ensuring that the graph is full scale. This state can be caused in many ways, but I have one check for it. However on reviewing results, it's quite time-consuming to work out where in a script the check failed, if it does.
Would it be better to duplicate the check, and give it a new name that relates to the action the script has just done? I.e. when it should be at full scale because I've pressed the "Home" button, call it "CheckHomed", and for when it should be at full scale because I've pressed the previous view button, call it "CheckPreviousView"? I will end up with tons of checks but is it worth it, for results readability? Your advice appreciated, many thanks.
Hi again DSquared, this is exactly why I have only one check currently. But am just wondering if duplicating it would make results easier to read...maybe I should split my stuff into smaller scripts and keep the same name for the check. That could be another way to go...?
Is this a moot point if you had an easier way to figure out where in the script the check failed? How about sorting your result log by the Result column so all the Faileds are at the top. That along with the Line Number column should be a dead giveaway. You might have other reasons to come up with a standard naming convention, but does this help your current situation?