SPONSORS:






User Tag List

Thanks Thanks:  0
Likes Likes:  0
Dislikes Dislikes:  0
Results 1 to 2 of 2
  1. #1
    Junior Member
    Join Date
    Oct 2006
    Posts
    29
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Total Downloaded
    0

    how to insert whenever....

    I am trying to insert whenever statement in a script using the navigation insert-> event->bitmap or screen. successfully i captured the area of screen. but whenever that exception is coming it is not executing whenever script.
    below is the code:

    Pause 3, tpPauseSeconds
    GUIObject.Type "{ExtRight}{ExtRight}"
    Pause 3, tpPauseSeconds
    GUIObject.Type "45091512"
    GUIObject.Type "{F1}"
    Pause 3, tpPauseSeconds
    GUIObject.Type "{F1}"
    Pause 10, tpPauseSeconds

    Whenever "GenericQuestion"


    Window("Application=EXTRA.EXE Caption='SESSION1 - EXTRA! Personal Client'").Attach
    GUIObject("ClassName=Afx Caption=''").Attach
    GUIObject.Type "gift{ExtRight}"
    Pause 5, tpPauseSeconds
    ---------------------------------------------------------
    Private Sub Script_Whenever(ByVal TheEvent As TPEvents.TEventGroup)
    If TheEvent.Name = "GenericQuestion" Then
    GUIObject.Type "{F7}"
    Pause 3, tpPauseSeconds
    GUIObject.Type "{ExtPageDown}"
    Pause 3, tpPauseSeconds
    GUIObject.Type "{Return}"
    Pause 3, tpPauseSeconds
    GUIObject.Type "{Return}{Return}{Return}"
    Pause 5, tpPauseSeconds
    GUIObject.Type "{F1}"
    Pause 2, tpPauseSeconds
    End If
    End Sub
    ------------------------------------------------

    It is not going to Script_whenever() at all..please help...

    Or is there any other way to insert the whenever event?

  2. #2
    Member
    Join Date
    Oct 2006
    Posts
    62
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Total Downloaded
    0

    Re: how to insert whenever....

    Try inserting it at the very beginning of your script, I had issues with whenever events not working and when I added it at the beginning I have had no issue thus far. It is worth a try.

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Search Engine Optimisation provided by DragonByte SEO v2.0.36 (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Resources saved on this page: MySQL 11.11%
vBulletin Optimisation provided by vB Optimise v2.6.4 (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging v3.2.8 (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
vBNominate (Lite) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Feedback Buttons provided by Advanced Post Thanks / Like (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Username Changing provided by Username Change (Free) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
BetaSoft Inc.
Digital Point modules: Sphinx-based search
All times are GMT -8. The time now is 10:19 AM.

Copyright BetaSoft Inc.