Results 1 to 4 of 4
  1. #1

    Strange behaviour of tp.exe

    I am trying to run a TP script from command line
    as follows

    c:\>tp -u testuser -p pass -r Common -s script1

    I am getting error
    ERROR : Script script1 is not found!

    I have checked throughly - to make sure that script1 (Name with proper case) is present in Common project. I have check to see if project name is wrong by entering project name wrong - TP catches that - saying project not found.
    I tried giving wrong user name or password - TP catches that also. I did all this to make sure that all other parameters are correct.

    This can not be a permission issue as I am admin.

    When I enabled the verbose mode of TP.exe - this is what was displayed

    Username : testuser
    Password : pass
    Project : Common
    Scripts : script1

    Append Log : False
    Increment Log : False
    Verbose Mode : ON

    Searching projects...

    Project name: Common

    Project 'Common' found.

    Searching scripts...

    Script name: test

    ERROR: script script1 not found!

    Why TP.exe is searching for "test" and reporting that "script1 not found"

    I tried renaming the script that I am working with as "test" - tp could find the script and run it. But did not seem to be exeecute the code
    (the script had just one line - MsgBox ("hi")

    Does this mean - script name to be executed using tp has to be "test"?

    Other thing is when I changed the script location from Common to Project "Project1" - tp is again cribbing that "Project1" not found and attempting to look for script in common project

    Any clues as why this happening?

    Shrini Kulkarni
    Test Consultant

  2. #2
    Senior Member
    Join Date
    Apr 2003
    Wisconsin, USA

    Re: Strange behaviour of tp.exe

    Call compuware tech support. I think they will probably want to look at your database.

    Did you go to the database maintenance utility and see if there is any repairs that are needed? Maybe some indexes are wacko.

  3. #3

    Re: Strange behaviour of tp.exe

    Are you using the original DSN of TestPartner on your machine? You are not specifying it in your command line.

  4. #4

    Re: Strange behaviour of tp.exe

    Hi Shrini,You must include the Database name reference in your syntax for running scripts from Command prompt.I mean to say that u should also include "-d TestPartner" before specifying the project name.



Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
BetaSoft Inc.
All times are GMT -8. The time now is 07:47 PM.

Copyright BetaSoft Inc.