SPONSORS:






User Tag List

Thanks Thanks:  0
Likes Likes:  0
Dislikes Dislikes:  0
Results 1 to 7 of 7
  1. #1
    Member
    Join Date
    Aug 2002
    Posts
    61
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Total Downloaded
    0

    Delay in Recording SAP Portal

    We are testing a SAP Portal using TP. When i start recording for any screen within the Portal, TP becomes standstill for about half a minute and then it starts recording. In this process sometimes it does not record at all and we close TP and then re-open it. Then, It does recording but still waits for approx half a minute before recording.

    Same thing happens for any new screen that appears during recording.

    Please Advise !

  2. #2
    Senior Member
    Join Date
    Sep 2001
    Location
    Philly
    Posts
    1,231
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Total Downloaded
    0

    Re: Delay in Recording SAP Portal

    The TP 5.1.1 release notes say that SAP GUI for HTML has to running in Internet Explorer 5.5 or 6.0. Is this the case?

    Otherwise, sounds like a tech support question, as there is no "setting" that will change that behavior. http://frontline.compuware.com/

    Hope this helps...
    ~Alias~

  3. #3
    Member
    Join Date
    Aug 2002
    Posts
    61
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Total Downloaded
    0

    Re: Delay in Recording SAP Portal

    We are running in IE5.5 and also tried IE6.0. With IE 6.0, we get a Test Partner Error which we have already forwarded to the compuware support people.

    Thanks for help, i was wondering if there is anything in setting that can change the behavior.

  4. #4
    Senior Member
    Join Date
    Jun 2002
    Location
    farmington hills, MI, US
    Posts
    713
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Total Downloaded
    0

    Re: Delay in Recording SAP Portal

    Sounds like an enumeration problem. TestPartner will enumerate all the controls on a page, so if there are alot of controls to enumerate then you may see this type of behavior. This would also explain why the problem occurs when going to a new page. As a test you might want to try creating a new property check to see how long it takes to complete. If it takes a while then it is a good indication that this is the problem. I found a page last week that I couldn't do a property check on because it would cause TestPartner to crash. I was quite suprised until I took a look at the source code and found that it was over 300 pages long.

  5. #5
    Member
    Join Date
    Aug 2002
    Posts
    61
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Total Downloaded
    0

    Re: Delay in Recording SAP Portal

    Thanks, I tend to agree but there are some occasions when there are not many controls (in my opinion) and Test Partner takes some time, For example a small window confirming if the changes are to be saved or not.
    However, the suggestion you are making is to create the property check for the whole page? Interestingly, Test Partner takes 15-30 sec in most of our checks, so we thought that is the standards with TestPartner.
    I will try the property check and see.

  6. #6
    Member
    Join Date
    Aug 2002
    Posts
    61
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Total Downloaded
    0

    Re: Delay in Recording SAP Portal

    I just created property checks for My application and QA Forum links page. QA forum page had 414 objects and SAP Portal had 442 objects. The process for creating the property check for QAforum page was completed in 15 seconds while SAP Portal took about 4 minutes to complete. The total no of objects does not differ much but probably the type of objects that are in SAPPortal take more time than that in QAForum.

    SAP Portal is a system generated web page of SAP GUI by ITS Server. Hence,i think, the objects are generated at run time and take more time to be captured. I am not sure just thinking !

  7. #7
    Senior Member
    Join Date
    Sep 2001
    Location
    Philly
    Posts
    1,231
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Total Downloaded
    0

    Re: Delay in Recording SAP Portal

    One thing to think about is how much info the Property check is pulling in. Since you are using a Browser based app... you may want to try the Browser Check. It is a pre-templated property check, that only pulls in 1-2 properties for each web component. Not sure if it will speed up capture, but likely will spead up playback.

    You activate the browser check with a HotKey combo only... (I believe it is alt F5) BTW... You can create a property check, set all of your exclusions, and then manually apply the template of that check to any new checks.

    Let us know if this worked.
    ~Alias~

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Search Engine Optimisation provided by DragonByte SEO v2.0.36 (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Resources saved on this page: MySQL 10.71%
vBulletin Optimisation provided by vB Optimise v2.6.4 (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging v3.2.8 (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
vBNominate (Lite) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Feedback Buttons provided by Advanced Post Thanks / Like (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Username Changing provided by Username Change (Free) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
BetaSoft Inc.
Digital Point modules: Sphinx-based search
All times are GMT -8. The time now is 04:44 PM.

Copyright BetaSoft Inc.