SPONSORS:






User Tag List

Thanks Thanks:  0
Likes Likes:  0
Dislikes Dislikes:  0
Results 1 to 5 of 5
  1. #1
    Junior Member
    Join Date
    Jun 2008
    Posts
    3
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Total Downloaded
    0

    Failed to find the attach name

    Hi All,

    Apologies if this has been asked before, i did a brief search and couldnt find it.

    Anyways, my problem is: the majority of my scripts are now failing with a "Failed to find the attach name" error.

    The scripts give this error when there is a pop up message box that needs to be clicked.

    Any ideas how i can get test partner to find and click these messages boxes?

  2. #2
    Junior Member
    Join Date
    Dec 2008
    Posts
    10
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Total Downloaded
    0

    Re: Failed to find the attach name

    Use SetFocus method on thess messageboxe's and then click ok / Cancel button.

    window(XYZ).setfocus
    Button(OK).click


    Hope this helps

  3. #3
    Junior Member
    Join Date
    Jun 2008
    Posts
    3
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Total Downloaded
    0

    Re: Failed to find the attach name

    Thanks, will try that today

  4. #4
    Senior Member
    Join Date
    Jul 2001
    Location
    USA
    Posts
    104
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Total Downloaded
    0

    Re: Failed to find the attach name

    You can alleviate those errors by using tpAttachWait and tpAttachNoWait parameters with your attach commands. The syntax looks like this:
    Window("Application=IEXPLORE.EXE Caption='Select - Patient -- Webpage Dialog'", tpAttachNoWait).Attach

    The length of time to wait is controlled by the parameter Playback.AttachTimeOut, which is a value in seconds.

    J Hedges
    TP 6.3
    AUT: Web app - Java/SQL
    Using TestPartner since 2008
    Using QTP since 2002

  5. #5
    Member
    Join Date
    Apr 2007
    Location
    India
    Posts
    64
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Total Downloaded
    0

    Re: Failed to find the attach name

    Its a good question.

    If those windows are expected then handle with code.
    ie by clicking on the ok button or cancel btn as per your
    requirement. If not, Are they bugs? If so you have to use error handling methods.

    This is my analysis as per my understanding...
    Goodluck

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Search Engine Optimisation provided by DragonByte SEO v2.0.36 (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Resources saved on this page: MySQL 9.68%
vBulletin Optimisation provided by vB Optimise v2.6.4 (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging v3.2.8 (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
vBNominate (Lite) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Feedback Buttons provided by Advanced Post Thanks / Like (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Username Changing provided by Username Change (Free) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
BetaSoft Inc.
Digital Point modules: Sphinx-based search
All times are GMT -8. The time now is 12:06 AM.

Copyright BetaSoft Inc.