I'm using QARun 4.9.1 SP2 to test an application that is written in WinScape (an older terminal emulator style language).

I'm having a problem using the TextSelect function to locat text on the window.

When I Capture the screen and then display the results in a messagebox I can clearly see all the text.

I then issue a TextSelect to locate text in the screen. If I enter my Text parameter with more than 2 characters the function fails but if it's 2 or less it's fine.

As an example, I'm searching for the word 'Hello'.

If I enter the command:


it fails. However if I enter any of the following:


it works perfectly.

This is happening to me only on one specific machine. The machine was built in France so I have had to change everything to English based to even get QARun to run properly.

I've tried changing keyboard, mouse, display settings. I've tried re-installing QARun. I've tried re-installing my application but still without any luck.

I have also recorded a script and when I use the mouse to click on text on the screen it is also only 'reading' two characters maximum instead of whole strings. Again this only happens on this one PC.

I've tried doing the same thing in Microsoft Word and everything is fine, it successfully reads full strings.

Any thoughts?

Thanks in advance