SPONSORS:






User Tag List

Thanks Thanks:  0
Likes Likes:  0
Dislikes Dislikes:  0
Results 1 to 3 of 3
  1. #1
    Member
    Join Date
    Feb 2005
    Location
    Bangalore, India
    Posts
    303
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Total Downloaded
    0

    Error while using ~ActiveApp/

    Hi All,

    I tried to use "~ActiveApp/" as below

    Before
    <font class="small">Code:</font><hr /><pre>
    [-] window DialogBox LoginWebPageDialog
    [ ] tag "Login -- Web Page Dialog"
    [ ] parent Browser
    [ ]
    [-] window BrowserChild Login
    [ ] tag "Login"
    [ ] parent LoginWebPageDialog
    [-] HtmlPushButton No2
    [-] multitag "No[2]"
    [ ] "#6"
    [ ] "$btnNo"

    </pre><hr />
    I Changed the above as
    <font class="small">Code:</font><hr /><pre>
    [-] window BrowserChild Login
    [ ] tag "~ActiveApp/[DialogBox]Login -- Web Page Dialog"
    [-] HtmlPushButton No2
    [-] multitag "No[2]"
    [ ] "#6"
    [ ] "$btnNo"

    </pre><hr />
    When i tried to run the script using the follwing testcase
    <font class="small">Code:</font><hr /><pre>
    [-] testcase Test1 () appstate none
    [-] recording
    [ ] Login.SetActive( )
    [ ] Login.No2.Click ()
    </pre><hr />
    Iam getting the following error
    *** Error: Window '[MainWin]$explorer6_DOM[1]~ActiveApp' was not found

    Note: when i used window identifier for that object, it returned
    <font class="small">Code:</font><hr /><pre>
    Browser.DialogBox("Login -- Web Page Dialog").BrowserChild("Login").HtmlPushButton("No[2]|#6|$btnNo")
    </pre><hr />

    If i use the following tag, it works fine
    <font class="small">Code:</font><hr /><pre>
    tag "~/[DialogBox]Login -- Web Page Dialog/[BrowserChild]Login" </pre><hr />
    but not for this
    <font class="small">Code:</font><hr /><pre>
    tag "~ActiveApp/[DialogBox]Login -- Web Page Dialog/[BrowserChild]Login" </pre><hr />

    What is the exact difference between ~/ and ~ActiveApp/

    Where am I doing wrong?

  2. #2
    Senior Member
    Join Date
    Apr 2006
    Posts
    285
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Total Downloaded
    0

    Re: Error while using ~ActiveApp/

    Seems like the problem is with the following:

    [-] window BrowserChild Login
    [ ] tag "~ActiveApp/[DialogBox]Login -- Web Page Dialog"
    [-] HtmlPushButton No2
    [-] multitag "No[2]"
    [ ] "#6" [ ] "$btnNo"

    Why you use BrowserChild while you need a DialogBox. Also BrowserChild class may have parent window defined explicitly. That's why it looks for parent and than adds ~ActiveApp tag

  3. #3
    Member
    Join Date
    Feb 2005
    Location
    Bangalore, India
    Posts
    303
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Total Downloaded
    0

    Re: Error while using ~ActiveApp/

    Thanks Kanon [img]/images/graemlins/smile.gif[/img]

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Search Engine Optimisation provided by DragonByte SEO v2.0.36 (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Resources saved on this page: MySQL 11.54%
vBulletin Optimisation provided by vB Optimise v2.6.4 (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging v3.2.8 (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
vBNominate (Lite) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Feedback Buttons provided by Advanced Post Thanks / Like (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Username Changing provided by Username Change (Free) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
BetaSoft Inc.
Digital Point modules: Sphinx-based search
All times are GMT -8. The time now is 12:34 PM.

Copyright BetaSoft Inc.