We just upleveled from 2.1.4 to 5.0 and found many of our intermittant
problems, especially problems with Netscape 4, are now solved. We
are not yet testing under IE browsers, so I can't say if things are
better or worse with those browsers.

But do be aware:

1. There is no longer support for Powerbuilder in Silk 5.0.

2. And--to me more unbelievable--support for the Internet Explorer
3 browser has been dropped. (Segue support suggests using
version 2.1.4 to test your web app under that browser--which I
suspect will be a "challenge" to get complex scripts to work under
the two releases, reliably).

- fyi, Terry Horwath