SPONSORS:






User Tag List

Thanks Thanks:  0
Likes Likes:  0
Dislikes Dislikes:  0
Page 1 of 2 12 LastLast
Results 1 to 10 of 11
  1. #1
    Member
    Join Date
    Oct 2001
    Posts
    128
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Total Downloaded
    0

    Problem with window tag: special character

    Hi,
    Need input regarding the following:
    Its a Web app. IE 6.0 / Win 2k / Silk 6.0
    Now, few pages show up with captions starting with same words eg: ABC Inc
    The actual captions for these pages are longer including special character: TM
    Silk seems to have an issue with this special character/word - TM & does not read the tag beyond the initial co. name. So, all the pages are seen as same & hence the problem with unique identification.

    Any suggestion is appreciated.

    Rgds.
    quality - a way of life!

  2. #2
    Senior Member
    Join Date
    Jul 2001
    Location
    Elizabeth, CO, USA
    Posts
    653
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Total Downloaded
    0

    Re: Problem with window tag: special character

    Could you post the HTML for the <title> of the page? TM is not a special HTML character (that I'm aware of). I can put it in a title by brute force.



    But you're right: SilkTest just gives up after that point.

    Log it as a bug with Segue. I've attached a sample. May help you convince them.

    Good luck.

    - Dave


    Special Caption Sample
    WaltzingRhino.com
    A concerned Borland customer, a fly in the ointment, a wrench in the works.

  3. #3
    Senior Member
    Join Date
    Feb 2000
    Posts
    1,497
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Total Downloaded
    0

    Re: Problem with window tag: special character

    Can you show us an example?

    The fix is usually to replace the special characters in the tag for the affected object with asterisks or question-marks.


    John

  4. #4
    Member
    Join Date
    Oct 2001
    Posts
    128
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Total Downloaded
    0

    Re: Problem with window tag: special character

    The HTML for <TITLE> is:
    <TITLE>ABCInc™ Research for Small Firms</TITLE>

    Silk reads only ABCInc for the tag.
    quality - a way of life!

  5. #5
    Senior Member
    Join Date
    Jul 2001
    Location
    Elizabeth, CO, USA
    Posts
    653
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Total Downloaded
    0

    Re: Problem with window tag: special character

    Originally posted by John J. Miller:
    Can you show us an example?
    John
    <font size="2" face="Verdana, Arial, Helvetica">John,
    The attachment in my message reproduces it. SilkTest just stops at the TM and doesn't seen that or anything after it. Very handy.

    - Dave
    WaltzingRhino.com
    A concerned Borland customer, a fly in the ointment, a wrench in the works.

  6. #6
    Senior Member
    Join Date
    Aug 2003
    Location
    NY
    Posts
    708
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Total Downloaded
    0

    Re: Problem with window tag: special character

    Hi,

    the workaround suggested by John should work. change your tags to sth like this:


    tag "ABCInc*Research for Small Firms"

    HTH

  7. #7
    Senior Member
    Join Date
    Jul 2001
    Location
    Elizabeth, CO, USA
    Posts
    653
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Total Downloaded
    0

    Re: Problem with window tag: special character

    Originally posted by Harshil:
    the workaround suggested by John should work. change your tags to sth like this:

    tag "ABCInc*Research for Small Firms"

    <font size="2" face="Verdana, Arial, Helvetica">But it won't. Try it. SilkTest stops recognizing the caption at the TM and sees nothing after it. Nada. Nil. Not a sausage.

    It's a bug in SilkTest. Plain and simple. The only possible workaround is to go to your developers and beg them to change the captions of your pages to not include that special character.

    - Dave
    WaltzingRhino.com
    A concerned Borland customer, a fly in the ointment, a wrench in the works.

  8. #8
    Senior Member
    Join Date
    Jul 1999
    Location
    Bellingham, WA USA
    Posts
    1,323
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Total Downloaded
    0

    Re: Problem with window tag: special character

    That is a workaround, but it is an unrealistic expectation, and one I'm betting the developers will reject. This needs to be fixed.

  9. #9
    Senior Member
    Join Date
    Jul 1999
    Location
    Bellingham, WA USA
    Posts
    1,323
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Total Downloaded
    0

    Re: Problem with window tag: special character

    Just a shot in the dark, but you might try placing ampersand pound 153; in the tag in place of the TM.

    [ 09-10-2003, 07:14 AM: Message edited by: DJGray ]

  10. #10
    Senior Member
    Join Date
    May 2002
    Posts
    448
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Total Downloaded
    0

    Re: Problem with window tag: special character

    Guys,

    Is this a problem with only Silk 6.0 ? Well I'm using Silk 5.0.3.2 and it seems to be working.

    I'm trying out the Special Caption Sample provided by David, and SilkTest is able to uniquely identify the window, it also returns the tag of the window correctly. I have two similar pages with unique tags like

    Company Name - First Page
    Company Name - second Page


    I identify the first page, capture the tag then click a link to go to the second page. Then Identify the second page, capture the tag and click another link to go the first page.

    The tags are printed to the results file as shown below,


    </font><blockquote><font size="1" face="Verdana, Arial, Helvetica">code:</font><hr /><pre style="font-size:x-small; font-family: monospace;">[ ] Identified the first page, the tag is ...
    [ ] /[DialogBox]Company Name - First Page - Microsoft Internet Explorer
    [ ] Identified the second page, the tag is ...
    [ ] /[DialogBox]Company Name - Second Page - Microsoft Internet Explorer</pre><hr /></blockquote><font size="2" face="Verdana, Arial, Helvetica">You guys can kick me if I'm doin something wrong, haven't worked much with browsers [img]images/icons/wink.gif[/img]

    One other stupid question, does the editor font have anything to do with this ?
    Life, that dares send, A challenge to his end,
    And when it comes say, Welcome friend.

 

 
Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Search Engine Optimisation provided by DragonByte SEO v2.0.36 (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Resources saved on this page: MySQL 9.38%
vBulletin Optimisation provided by vB Optimise v2.6.4 (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging v3.2.8 (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
vBNominate (Lite) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Feedback Buttons provided by Advanced Post Thanks / Like (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Username Changing provided by Username Change (Free) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
BetaSoft Inc.
Digital Point modules: Sphinx-based search
All times are GMT -8. The time now is 06:07 AM.

Copyright BetaSoft Inc.