SPONSORS:






User Tag List

Results 1 to 7 of 7
  1. #1
    Senior Member
    Join Date
    Jun 2002
    Posts
    119
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Always something new - now it\'s stalling at Browser.Exists(60)

    Always something new and exciting -- I've been adapting the scripts I wrote for our web app, originally written on IE 5.5, and lately I've adapted them to run on |IE 5.0 and 6.0. The 5.0 actually has some differences in the way SilkTest reads things, but 6.0 has been very little different.

    But lots of little puzzlers have arisen. Starting yesterday, after maybe a week of fooling with them, they started stalling out right at the beginning of running a .pln -- the Status window shows the call is to Browser.Exists(60). The only time I've seen that before was when a colleague saw it and it turned out that he was running IE 6.0 on his machine, but had the browser extension set to 5xDOM. When he set it to 6DOM, it stopped doing it.

    But I'm definitely running 6.0 on this machind, and definitely it's set to the 6DOM extension. And it's intermittent. At the end of the day yesterday, it happened, and I tried all kinds of things to kick it around - starting, stopping, rebooting, running things from the script level, the testcase level, the miniplan and master plan level, gave up. This morning it was still locked, so I cursed and did other things. Later in the morning it worked fine, without any change that I'm aware of.

    Any clue on this one?

    ------------------

  2. #2
    Super Member
    Join Date
    Jul 2001
    Location
    Earth
    Posts
    1,882
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Always something new - now it\'s stalling at Browser.Exists(60)

    I got tired and wanted to be restarted?

    ------------------
    James Soderborg
    http://www.ameliortech.com
    jamesso@ameliortech.com

  3. #3
    Member
    Join Date
    Feb 2001
    Location
    Charleston, SC
    Posts
    37
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Always something new - now it\'s stalling at Browser.Exists(60)

    Did you try the latest build? 6.0Sp1 has some dom fixes....not sure if they relate to your problem but it's a good place to start.

    ------------------
    Jeff

  4. #4
    Senior Member
    Join Date
    Jun 2002
    Posts
    119
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Always something new - now it\'s stalling at Browser.Exists(60)

    jamesso - who knows? It's been working again just fine this morning

    jcorwin - I've been very hesitant to upgrade to 6. I've seen enough mentions here of testers unhappy with things. I've found my scripts to be very very ticlish. I spend most of my time trying to figure out what went wrong, that they are failing today when they ran yseterday. The developers, too - without developers around, my job would be a lot easier!! rant, rant ...

    Anyway, I've wondered if Silk 6 would drive me crazy with all kinds of little differences that would need rewriting of my code. I't well over 200 pages by now, and I'm all alone here.

    Thanks guys. It's been a frustrating week.



    ------------------

  5. #5
    Senior Member
    Join Date
    Jul 1999
    Location
    Bellingham, WA USA
    Posts
    1,323
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Always something new - now it\'s stalling at Browser.Exists(60)

    felecha,

    I honestly didn't have to tweak my scripts too much moving from 5.5 to 6.Ox.



    ------------------

  6. #6
    Member
    Join Date
    Oct 2002
    Location
    Earth (I think!)
    Posts
    92
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Always something new - now it\'s stalling at Browser.Exists(60)

    Does you AUT use JScript? I've noticed that with IE 5, it seems that the message sent to the browser was never serviced until the JScript had finished running. I looked at IE 6.0 with my sample code but didn't encounter a delay.

    However, with a large script I had noticed that the agent DLL's went a little haywire with timing issues. Especially Exists() and WaitForReady(). Not sure if the agent memory got stepped on and a timing variable was extended or what.

    anyway, just some thoughts that might trigger something on your end.

    ------------------


    [This message has been edited by Shane DeMorais (edited 02-18-2003).]
    Let go Luke!

  7. #7
    Senior Member
    Join Date
    Jul 1999
    Location
    Bellingham, WA USA
    Posts
    1,323
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Always something new - now it\'s stalling at Browser.Exists(60)

    I'm testing a new web app, and the nav items (menus and tabs) are done in JavaScript to produce a highlight effect on mouseover. The interesting thing here is that, in Netscrap, SilkTest does not see the navigatinal tabs and menu "links" as links, but rather as HtmlText, so the script needs to know that the current browser is NS and deal with that appropriately.

    So, I'm not seeing any great challenges that are 6.0 specific. There are some oddities. For example, there are times when I cannot set breakpoints. ST gets into an odd state and I have to shut it down and restart to get it to allow breakpoints. Another odd thing is that on occasion, I will comment out a section of code, and Silk will still run it as though it is uncommented, and will ignore the current uncommented code as though it is still commented.

    Both of those have been logged with Segue, but they are seemingly random, and Segue cannot reproduce them, so there isn't much they can do in the way of a fix. There are probably other things that have slipped my mind, but nothing earth-shattering.

    ------------------

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

vBulletin Optimisation provided by vB Optimise v2.6.0 Beta 4 (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging v3.0.9 (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Questions / Answers Form provided by vBAnswers (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
vBNominatevBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Feedback Buttons provided by Advanced Post Thanks / Like (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Username Changing provided by Username Change (Free) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
BetaSoft Inc.
Digital Point modules: Sphinx-based search
All times are GMT -8. The time now is 09:07 AM.

Copyright BetaSoft Inc.