SPONSORS:






User Tag List

Results 1 to 8 of 8
  1. #1
    Member
    Join Date
    Jan 2003
    Location
    Caribou, ME, USA
    Posts
    38
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Not seeing anything when using Record Class with VB6 app

    Greets all! We're wrestling with a few 3rd party controls in a VB6 application that we're setting up to test. Right now we're dealing with Sheridan's DataWidgets Grid (SSDBGrid). Lots of places (including the QAforums archives) point us to the Record Class feature of Silk. When we try to use this feature, however, we never see any Properties or Methods.

    I don't just mean for the grid control either. I mean we've never actually seen a single property or method on any control that we've ever selected. This includes VB buttons, dialogs and text boxes. We can hover over anything, press Crtl-Alt and nothing ever appears in the Properties or Methods windows.

    Perhaps we just don't understand how this tool is supposed to work. Can someone enlighten us?

    -Greg
    Greg
    ATX II, LLC
    You wrote [i]what</I] in 4Test?!?

  2. #2
    Member
    Join Date
    Jan 2003
    Location
    Caribou, ME, USA
    Posts
    38
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Not seeing anything when using Record Class with VB6 app

    FWIW, the control in question is the Sheridan DataGrid/Combo/DropDown 3.1 and is supplied via ssdw3b32.ocx

    -Greg
    Greg
    ATX II, LLC
    You wrote [i]what</I] in 4Test?!?

  3. #3
    Member
    Join Date
    Oct 2002
    Location
    Alameda, CA
    Posts
    50
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Not seeing anything when using Record Class with VB6 app

    Are you hooked into the application (using the expentions enabler)? The format in the Partner.ini is :

    [Extension: project1.exe]
    ActiveX=TRUE

    Where project1.exe is your executable name.

    How you go about getting this into the file depends slightly on which version of silk test you are running... unless you enter it by hand.

    That may help it get the clas deatil info.

    ------------------
    -Josh
    -Josh

  4. #4
    Member
    Join Date
    Jan 2003
    Location
    Caribou, ME, USA
    Posts
    38
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Not seeing anything when using Record Class with VB6 app

    Josh,

    That line did NOT exist in my partner.ini file although I did use the Extensions option to add the EXE. I put the section in my INI and re-started Silk, but unfortunately it didn't seem to make any difference. Any other tips?

    -Greg
    Greg
    ATX II, LLC
    You wrote [i]what</I] in 4Test?!?

  5. #5
    Member
    Join Date
    Oct 2002
    Location
    Alameda, CA
    Posts
    50
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Not seeing anything when using Record Class with VB6 app

    What version of Silk are you running? If &lt;6.0 then enable extensions both in Silk Test and also on the agent (the extensions enabler on the start menu).

    ------------------
    -Josh

    [This message has been edited by VolleyJosh (edited 01-22-2003).]
    -Josh

  6. #6
    Member
    Join Date
    Jan 2003
    Location
    Caribou, ME, USA
    Posts
    38
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Not seeing anything when using Record Class with VB6 app

    Josh,

    We're using v6.0 so I guess enabling the extension on the agent doesn't apply. Bummer.

    -Greg
    Greg
    ATX II, LLC
    You wrote [i]what</I] in 4Test?!?

  7. #7
    Member
    Join Date
    Oct 2002
    Location
    Alameda, CA
    Posts
    50
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Not seeing anything when using Record Class with VB6 app

    Well, try using the UI to add it- prehaps it adds some entries in other places.

    ------------------
    -Josh
    -Josh

  8. #8
    Member
    Join Date
    Jan 2003
    Location
    Caribou, ME, USA
    Posts
    38
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Not seeing anything when using Record Class with VB6 app

    The UI is what we used to add the extension in the first place. I have a case that's been open for a couple of days on this with Segue. Looks like we'll just have to wait and hear from them.

    -Greg

    ------------------
    Greg
    ATX II, LLC
    You wrote [i]what</I] in 4Test?!?

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

vBulletin Optimisation provided by vB Optimise v2.6.0 Beta 4 (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging v3.0.9 (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Questions / Answers Form provided by vBAnswers (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
vBNominatevBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Feedback Buttons provided by Advanced Post Thanks / Like (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Username Changing provided by Username Change (Free) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
BetaSoft Inc.
Digital Point modules: Sphinx-based search
All times are GMT -8. The time now is 12:21 AM.

Copyright BetaSoft Inc.