SPONSORS:






User Tag List

Results 1 to 4 of 4
  1. #1
    Junior Member
    Join Date
    Jan 2003
    Location
    India
    Posts
    6
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Getting error ; \" Window \'[MainWin]$explorer6_DOM[1]\' is not enabled \"

    Hi
    I am using silktest 5.5.3 and IE 6.0
    After this piece of code i am getting that above error..
    Browser.LoadPage("xxx")

    Can anyone provide me with solution?

    Thanks
    Hari

    ------------------
    Hari
    Hari

  2. #2
    Junior Member
    Join Date
    Sep 2001
    Location
    WestBorough
    Posts
    13
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Getting error ; \" Window \'[MainWin]$explorer6_DOM[1]\' is not enabled \"

    Hi Hari,

    You need to make sure the following things.
    1) Go to Start->Programs->SilkTest->Extension Eanbler
    Open the Extension Enabler window.
    For Application IE6.0 select the primary Extension as IE DOM and click Ok.
    2)Open Silk Test Application
    In the options Menu Select Extensions
    Select IE 6.0 here also for Primary Extension
    3)In the Runtime options Select default browser as IE 6.0 DOM.

    Hope it helps.

    Srini


    ------------------


    [This message has been edited by Srinis (edited 01-21-2003).]

  3. #3
    Member
    Join Date
    Aug 2002
    Location
    Durham, NC USA
    Posts
    60
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Getting error ; \" Window \'[MainWin]$explorer6_DOM[1]\' is not enabled \"

    I see this error if I have a dialog box (e.g. a login prompt, security dialog) open when I make the call. When Silk tries to set the focus on the IE window, the dialog box comes up instead. (Popups could possibly cause this, if the timing was just wrong, but that's not especially likely.)

    Perhaps there is a warning or prompt popping up just before the call is made? You can just click it away, or enclose the whole thing in its own testcase. If not, you can increase your window timeout in Options/Agent; maybe the computer is just unusually slow on that particular page.

    It might be worth putting in a Browser.SetActive () just before this command. It might help in debugging, or at least give you another point of reference.

    -TC


    ------------------
    --
    Tim Crone
    Broadcom

  4. #4
    Junior Member
    Join Date
    Jan 2003
    Location
    South Grafton ,MA,USA
    Posts
    1
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Getting error ; \" Window \'[MainWin]$explorer6_DOM[1]\' is not enabled \"

    I was getting the same error. My app had another window open after login in that was being seen as a popup window and not as a dialog box.
    Support had me install 6.0.0.1 [5] and now it works fine.

    Chuck

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

vBulletin Optimisation provided by vB Optimise v2.6.0 Beta 4 (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging v3.0.9 (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Questions / Answers Form provided by vBAnswers (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
vBNominatevBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Feedback Buttons provided by Advanced Post Thanks / Like (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Username Changing provided by Username Change (Free) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
BetaSoft Inc.
Digital Point modules: Sphinx-based search
All times are GMT -8. The time now is 10:56 AM.

Copyright BetaSoft Inc.