SPONSORS:






User Tag List

Results 1 to 4 of 4
  1. #1
    Guest

    SYS_Execute command

    Can SYS_Execute take in command line arguments? If so, is there a special way of passing them in?

    The following is my code. "message.exe" is the executable that takes a file name as the command line argument. Each time I pass in the file name, execute fails.

    [ ] list of string MessageOutput
    [ ] integer RunMessage
    [ ]
    [ ] RunMessage = SYS_Execute ("message.exe rhonda.msg", MessageOutput)

  2. #2
    Junior Member
    Join Date
    Aug 1999
    Location
    mt view, Ca
    Posts
    8
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: SYS_Execute command

    Hi Rhonda,
    As I understand it you are looking for a way to run a process other than the app under test, and then proceed with your app. There is another command available from the bwcompat.inc file included in your QAP/Silk directory, APP_Start(sCmdLine). Include bwcompat.inc with a USE stmt in your frame, then try APP_Start() in place of SYS_Execute(). It is similar to Start() but does not wait for the main window to exist, and I have been successful running apps, .bat files and others with it.
    Len Jagelski
    Automation Engineer
    Lotus, cc:Mail

  3. #3
    Guest

    Re: SYS_Execute command

    Rhonda,

    According to 2.1.2 version help page:
    "SYS_Execute is not supported on Windows 3.x, Windows 95, or the
    Macintosh."

    But,You imply that it works without the .msg parm... so you might try
    wrapping the entire first SYS_Execute parm in double quotes. Otherwise, I'd
    suppose that message.exe is failing in some way.

    I tried the following test on Windows NT4 which works just fine... Hope
    this helps!

    -rsh

    testcase junk ()
    {
    LIST OF STRING lsOut;
    INTEGER iRet;

    iRet = sys_execute ("dir c:\temp", lsOut);

    listprint (lsOut);
    }

  4. #4
    JP
    JP is offline
    Junior Member
    Join Date
    Jun 2001
    Location
    San Francisco, CA ,US
    Posts
    1
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: SYS_Execute command

    Where in the frame.inc do you write the statement for USE

    Can you give an eg? I also did not find the syntax of APP_Start in Help

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

vBulletin Optimisation provided by vB Optimise v2.6.0 Beta 4 (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging v3.0.9 (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Questions / Answers Form provided by vBAnswers (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
vBNominatevBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Feedback Buttons provided by Advanced Post Thanks / Like (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Username Changing provided by Username Change (Free) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
BetaSoft Inc.
Digital Point modules: Sphinx-based search
All times are GMT -8. The time now is 12:49 PM.

Copyright BetaSoft Inc.