SPONSORS:






User Tag List

Results 1 to 7 of 7
  1. #1
    Senior Member
    Join Date
    Nov 1999
    Location
    Eagle, ID,USA
    Posts
    1,035
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    TestPlan skipping tests

    Has anyone experienced TestPlan skipping testcase's? It seems to be a random problem with me. Sometimes it runs the whole plan and other times it doesn't. If you have experienced it, did you report it to Segue? Do you know the cause and/or workaround?

    I'm using 6.0 1122 baseline.

    ------------------
    Have you ever noticed? Anybody going slower than you is an idiot, and anyone going faster than you is a maniac.

  2. #2
    Senior Member
    Join Date
    Jun 1999
    Location
    Fremont, CA, USA
    Posts
    355
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: TestPlan skipping tests

    Are you using Attributes (for queries) within your test plan?

    If so, then make sure the Attributes listed within the test plan are in the testplan.ini file. If not, then the tests with the undefined Attributes will not be executed.



    ------------------
    David Genrich
    david.genrich@e2open.com
    david@linuxpuppy.net

  3. #3
    Senior Member
    Join Date
    Nov 1999
    Location
    Eagle, ID,USA
    Posts
    1,035
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: TestPlan skipping tests

    No. I'm not using attributes. It's clearly a bug with TestPlan as it happens sometimes but not others.

    ------------------
    Have you ever noticed? Anybody going slower than you is an idiot, and anyone going faster than you is a maniac.

  4. #4
    Senior Member
    Join Date
    Apr 2001
    Location
    San Diego,CA,USA
    Posts
    108
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: TestPlan skipping tests

    are you sure that for some reason the results didn't get nested in each other, because I have had some such problem where in results from one test got nested in other test and just by looking at it it seemed as if not all the tests have ran but looking closely I found out that other test results were there though nested

    do you use resopenlist etc in your functions or tescases?

    ------------------


    [This message has been edited by AUTOMATION_GURU (edited 01-07-2003).]

  5. #5
    Member
    Join Date
    Sep 2002
    Location
    Rancho Santa Margarita, CA, USA
    Posts
    42
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: TestPlan skipping tests

    Nope. I use the TestPlan all the time and have never seen this "skipping tests" problem.


    ------------------

  6. #6
    Senior Member
    Join Date
    Nov 1999
    Location
    Eagle, ID,USA
    Posts
    1,035
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: TestPlan skipping tests

    <BLOCKQUOTE><font size="1" face="Verdana, Arial, Helvetica">quote:</font><HR>are you sure that for some reason the results didn't get nested in each other, because I have had some such problem where in results from one test got nested in other test and just by looking at it it seemed as if not all the tests have ran but looking closely I found out that other test results were there though nested<HR></BLOCKQUOTE>

    I can see the test in the result and it is greyed out preceded by a diamond shaped bullet as if it was marked as a manual test. Like I said, I can run it once and see the problem and then rerun it again and not see the problem.

    ------------------
    Have you ever noticed? Anybody going slower than you is an idiot, and anyone going faster than you is a maniac.

  7. #7
    Senior Member
    Join Date
    Jul 2001
    Location
    Brookline,NH USA
    Posts
    147
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: TestPlan skipping tests

    Could it be a corrupt .jou file? Just guessing, as I have not seen this at all and always use testplans.

    I have seen an issue where the test results are displayed in the wrong place, submitted this to Segue and it has been forwarded to engineering as an enhancement request. Not sure why the support guy called it that because it is clearly a bug. Anyway, here is the scenario:

    - AUT has two user types, each has some pages that only that user type can see and there are common pages that all user types can see.
    - I have a master plan, with a sub-plan included twice. Once for each user type, and attributes set accordingly.
    - Example is 4 tests, 1 & 4 are on common pages, 2 is for 1st user type and 3 is for 2nd user type.
    - Results when running tests marked by named query should show the sub-plan twice: first time should have results for tests 1, 2, & 4; second should have results for tests 1, 3, & 4.
    - What actually ends up in the results file is first section for sub-plan has results for tests 1 through 4, and second section has results for tests 1 & 4 only (i.e., the results for test 3 are incorrectly listed in the first section).

    Regards,
    ~ Fred

    ------------------

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

vBulletin Optimisation provided by vB Optimise v2.6.0 Beta 4 (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging v3.0.9 (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Questions / Answers Form provided by vBAnswers (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
vBNominatevBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Feedback Buttons provided by Advanced Post Thanks / Like (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Username Changing provided by Username Change (Free) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
BetaSoft Inc.
Digital Point modules: Sphinx-based search
All times are GMT -8. The time now is 07:22 PM.

Copyright BetaSoft Inc.