SPONSORS:






User Tag List

Results 1 to 3 of 3
  1. #1
    Senior Member
    Join Date
    Nov 2001
    Location
    UK, Oxford
    Posts
    150
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    code complete crash in ST 6.0.0.1

    I temporarily turned on code complete. (ST 6.0.0.1)
    I typed in 'list of ' (space is important, to make it code complete)
    Silktest crashed.
    This happens consistently.
    I do not get this behaviour with ST 6.0.0.0 on another machine.
    (Both machines are win2K)

    Naturally enough I blame myself for turning on code completion, however, that done, has anyone else noticed this behaviour.


    ------------------
    Tempus fugit, Carpe Diem, et al

  2. #2
    Guest

    Re: code complete crash in ST 6.0.0.1

    I had seen at least 3-4 silk test crashes while using this feature. I reported them to Segue support with reproducable example code. They fixed them and told me to wait for next hotfix/update release.

    Here are 2 situations where I had similar problem.

    In both the cases, it is something to do with the compilation of script you are currently typing.

    1.) When there are 2 custom classes with same name, silk compilation fails & crashes.
    2.) When I do F12 on a method to go to definition of the method (in this case the definition doesn't exist), silk fails to find the definition and crashes.

    Everytime I encountered this error, I commented out everything in my script first. Then started uncommenting blocks of code & compile to isolate the issue. I could isolate the issue in all the cases and successfully use this feature.

  3. #3
    Member
    Join Date
    Aug 2002
    Location
    Raleigh
    Posts
    31
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: code complete crash in ST 6.0.0.1

    The issue can also be reproduced if while running a testcase on an agent machine, you try typing anything that will trigger the autocomplete. I've submitted it to Segue and it seems to be a conflict with compiling code (which autocomplete does automatically to enable custom classes, functions and the such) while the agent is doing something else. I am constantly running code while developing, so my solution was to turn autocomplete off until Segue releases a patch that will render autocomplete usable. Also, I just noticed that I can't use <ctrl-f> to find text while a test is running.

    ------------------

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

vBulletin Optimisation provided by vB Optimise v2.6.0 Beta 4 (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging v3.0.9 (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Questions / Answers Form provided by vBAnswers (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
vBNominatevBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Feedback Buttons provided by Advanced Post Thanks / Like (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Username Changing provided by Username Change (Free) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
BetaSoft Inc.
Digital Point modules: Sphinx-based search
All times are GMT -8. The time now is 11:03 AM.

Copyright BetaSoft Inc.