SPONSORS:






User Tag List

Page 1 of 2 12 LastLast
Results 1 to 10 of 17
  1. #1
    Junior Member
    Join Date
    Aug 2000
    Location
    Westford, MA, USA
    Posts
    12
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Web testing with SilkTest 6.0 is 100% slower than with SilkTest 5.5

    I did a simple benchmark test with 2 identical systems one with SilkTest 6.0 and one with SilkTest 5.5. Both ran the same script on the same browser (IE5.5 sp2) on the same OS (Win2000 1Ghz system). I've enclosed the script below and it runs on Segue's website http://www.segue.com/html/s_about/s_about.htm. It shows that SilkTest 6.0 web testing is almost 100% slower than SilkTest 5.5. This is a problem.

    I ran the benchmark test after realizing that
    it was taking SilkTest 6.0 almost twice as long to run my test suites. My test suite normally takes around 24 hours to run with SilkTest 5.5. Now with SilkTest 6.0 it takes nearly 44 hours to complete! That is unacceptable. I was really expecting an improvement in performance with SilkTest 6.0.

    Steps to reproduce benchmark:

    1. Open an IE 5.5 SP2 browser on a system with SilkTest 5.5 installed.

    2. Go to the segue web site "About Segue" page: http://www.segue.com/html/s_about/s_about.htm

    3. Open SilkTest 5.5 and run the following script:

    main()
    {
    int x;

    Browser.SetActive();

    for x = 1 to 10
    {
    BrowserPage.HtmlLink("company profile").Click();
    Browser.Back.CLick();
    BrowserPage.HtmlLink("investor relations").Click();
    Browser.Back.CLick();
    BrowserPage.HtmlLink("selected enterprise customers").Click();
    Browser.Back.CLick();
    BrowserPage.HtmlLink("careers").Click();
    Browser.Back.CLick();
    BrowserPage.HtmlLink("offices and distributors").Click();
    Browser.Back.CLick();
    BrowserPage.HtmlLink("legal notices").Click();
    Browser.Back.CLick();
    }

    print("Time: {ElapsedStr()}");
    }

    4. Now repeat steps 1,2 and 3 on the same or identical system except this time using SilkTest 6.0

    5. I'm consistently getting 38 seconds on SilkTest 5.5 and 73 seconds for SilkTest 6.0


    --Tony

    ------------------

  2. #2
    Member
    Join Date
    Oct 2002
    Location
    Alameda, CA
    Posts
    50
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Web testing with SilkTest 6.0 is 100% slower than with SilkTest 5.5

    Have you sent these results to Segue? What did they say?

    ------------------
    -Josh

    [This message has been edited by VolleyJosh (edited 11-19-2002).]
    -Josh

  3. #3
    Senior Member
    Join Date
    Feb 2000
    Posts
    1,497
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Web testing with SilkTest 6.0 is 100% slower than with SilkTest 5.5

    Have you verified that the Options/Agent values for the Timing and Verification tabs are identical between the two Silk versions?


    John


    ------------------

  4. #4
    Junior Member
    Join Date
    Oct 2002
    Location
    Westford, MA, USA
    Posts
    4
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Web testing with SilkTest 6.0 is 100% slower than with SilkTest 5.5

    Yes and yes.

    I sent this info to Segue to generate a bug. And yes the Agent Options were identical on both versions of SilkTest.

    ------------------

  5. #5
    Senior Member
    Join Date
    Jul 2000
    Location
    Walsall, West Midlands, United Kingdom
    Posts
    259
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Web testing with SilkTest 6.0 is 100% slower than with SilkTest 5.5

    Keep us informed please Tony.

    I still haven't had chance to check ST6 on our client/server app, when I do I'll let you know my findings.

    Thanks.

    ------------------

  6. #6
    Senior Member
    Join Date
    Jul 1999
    Location
    Bellingham, WA USA
    Posts
    1,323
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Web testing with SilkTest 6.0 is 100% slower than with SilkTest 5.5

    This discussion is particularly interesting to me because I've not noticed an increase or decrease on Win2k, but on XP, it is screaming fast. So much so that we had to put some delays into the agent options to slow things down a bit.



    ------------------

  7. #7
    Junior Member
    Join Date
    Aug 2001
    Posts
    8
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Web testing with SilkTest 6.0 is 100% slower than with SilkTest 5.5

    I am realizing a terrible performance issue as well with ST 6.0. I just bring up the Window Declaraions window and put it over a regular web page and the CPU spikes to 100%; all of it being used by the IEXPLORE.exe process. It takes a while for the WD window to update. This is is much more noticeable in the application which I am testing. My application is an hta and the mshta.exe process takes up all of the CPU. It takes approximately 20 minutes for the window to show the controls within my application. Many times during this messages pop up in ST statin that the Agent is not responding. When I clos my app the Agent still says IN USE until I have to manually shut the Agent down.

    ------------------

  8. #8
    Junior Member
    Join Date
    Aug 2001
    Posts
    8
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Web testing with SilkTest 6.0 is 100% slower than with SilkTest 5.5

    By the way my OS is Win2K SP2 and my browser is IE 6.0 SP1.

    ------------------

  9. #9
    Member
    Join Date
    Oct 2002
    Posts
    56
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Web testing with SilkTest 6.0 is 100% slower than with SilkTest 5.5

    Does silktest support HTA?

    ------------------

  10. #10
    Junior Member
    Join Date
    Aug 2001
    Posts
    8
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Web testing with SilkTest 6.0 is 100% slower than with SilkTest 5.5

    I have been told it does.

    ------------------

 

 
Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

vBulletin Optimisation provided by vB Optimise v2.6.0 Beta 4 (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging v3.0.9 (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Questions / Answers Form provided by vBAnswers (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
vBNominatevBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Feedback Buttons provided by Advanced Post Thanks / Like (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Username Changing provided by Username Change (Free) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
BetaSoft Inc.
Digital Point modules: Sphinx-based search
All times are GMT -8. The time now is 03:54 PM.

Copyright BetaSoft Inc.