SPONSORS:






User Tag List

Results 1 to 4 of 4
  1. #1
    Junior Member
    Join Date
    Jun 2002
    Posts
    12
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Question about DefaultBaseState

    When I use file/New/TestFrame to create a mainwindow frame, and DefaultBaseState will be generated by silktest automatically, it works ok, but today I installed silktest on another pc and created the main frame and just run DefaultBaseState, it failed, it always said as following:
    [ ] Script $ScriptMain - 1 error
    [ ] Machine: (local)
    [ ] Started: 05:17:49PM on 07-Aug-2002
    [ ] Elapsed: 0:00:05
    [ ] Totals: 1 error, 0 warnings
    [ ]
    [ ] *** DefaultBaseState is setting Browser active, No window was active
    [ ] *** Error: Window '[PushButton]View' was not found
    [ ] Occurred in IsChecked
    [ ] Called from Explorer.SetRequiredOptions at extend\domex.inc(780)
    [ ] Called from Browser.SetRequiredOptions at browser.inc(445)
    [ ] Called from DefaultBaseState at defaults.inc(232)
    [ ] Called from main at $ScriptMain(2)

    My environment is
    Win2000 server
    IE 5.5 sp2 (chinese simplified)
    silktest 5.0.3.2
    AUT is based on web

    Does the language of IE cause the problem?

    Thanks!


    ------------------

  2. #2
    Senior Member
    Join Date
    Jul 2000
    Location
    Walsall, West Midlands, United Kingdom
    Posts
    259
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Question about DefaultBaseState

    Have you compared your runtime options:-

    Is the frame in the Use Files section (unless you call it from your .t scripts).
    Is the correct Segue .inc file being included in the Use Files section, i.e. explorer.inc.

    Check your extensions are correct.

    Hope this helps.

    ------------------

  3. #3
    Junior Member
    Join Date
    Aug 2001
    Posts
    5
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Question about DefaultBaseState

    Sure, it's the language. In order to set the base state Silk has to drive the browser. Therefore it needs to identify its window objects (e.g. push buttons.) ...

    Segue sent us a localized version for German browsers upon request - perhaps they have something ready for Chinese.

    You also might be able to fix the problem yourself by carefully (!) modifying domex.inc and explorer.inc.

    good luck, mike

    ------------------

  4. #4
    Junior Member
    Join Date
    Jun 2002
    Posts
    12
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Question about DefaultBaseState

    Thank you for your reply, I think maybe I should install English version of IE. Another question is my os is Win2000 server in Chinese, does it effect the silk to identify object? In my opinion, it will not. I will try it tonight, Thanks again Mike.

    ------------------

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

vBulletin Optimisation provided by vB Optimise v2.6.0 Beta 4 (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging v3.0.9 (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Questions / Answers Form provided by vBAnswers (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
vBNominatevBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Feedback Buttons provided by Advanced Post Thanks / Like (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Username Changing provided by Username Change (Free) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
BetaSoft Inc.
Digital Point modules: Sphinx-based search
All times are GMT -8. The time now is 09:26 PM.

Copyright BetaSoft Inc.