SPONSORS:






User Tag List

Results 1 to 6 of 6
  1. #1
    Junior Member
    Join Date
    Jun 2002
    Location
    pune,maharashtra,india
    Posts
    20
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    unable to capture a mail with the subject field in silk test

    hello ,

    i am trying to capture the microsoft outlook send mail .

    the following is what i am trying:-
    1.open Microsoft outlook
    2.Select 'write new mail'
    3.type some email in the "to" field.
    4.Type some text in the "subject" field.
    5.Type some text in the "message" field.

    and then click on "send mail".
    record the above sequence and replay.

    but the silk test gives error after it reaches the subject field.Till the subject field ,the replay runs smoothly.After the subject field, it won't go in the message field.giving the following error

    the error shown was "
    Window '[dialog box] test mail -Message (plain text)' was not found
    Occured in Dialog box("test mail -Message (plain Text").CustomWin("[AfxWnd]#1|$103.DialogBox("#1|$0").CustomWin("[Rich edit20A] test mail |$4101")::TypeKeys)"

    Pls help.

    Regards,
    Suvarna.


    ------------------

  2. #2
    Junior Member
    Join Date
    May 2002
    Posts
    4
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: unable to capture a mail with the subject field in silk test

    Hi,

    You just try to write the script by just recording the windows declarations not by recording the whole testcase.Its more helpfull and more easiest way to write the scripts.And it improves your knowledge in writing silk scripts.

    And coming to the point you can use it as:-

    NewMessage.OE_Envelope1.RichEdit20W4.TypeKeys ("dsfgdG")

    where the NewMessage points to the window to send a new mail and OE_Envelope1 to the part of window where the From,To,cc,Bcc,Subject are placed.RichEdit20W4 points to the subject field.And by using TypeKeys we can just insert data into the field.

    This above statement is written by recording the window declarations.If you any more doubts you can contact me onmy personnel mailID-dsunil_kumar2002@yahoo.com

    Thanks,
    Sunil.

    ------------------

  3. #3
    Junior Member
    Join Date
    Jun 2002
    Location
    pune,maharashtra,india
    Posts
    20
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: unable to capture a mail with the subject field in silk test

    hi sunil,

    actually we are doing it from the silk test wizard.

    and the problem is when i type a subject the name of the window(dialog box , as it is recorded) changes and takes the text which we typed in the subject field.
    so the status of the window changes.
    and this window the silk test is unable to find at runtime.

    here lies the problem.
    I would prefer to find the solution by using the wizard itself,there should be some solution.

    Regards,
    Suvarna.

    ------------------

  4. #4
    Junior Member
    Join Date
    Jun 2002
    Location
    pune,maharashtra,india
    Posts
    20
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: unable to capture a mail with the subject field in silk test

    hi john,

    that's great!!

    thanks a LOT! it worked that way.

    regards,
    Suvarna.

    ------------------

  5. #5
    Senior Member
    Join Date
    Jul 1999
    Location
    Burlingame CA 94010
    Posts
    502
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: unable to capture a mail with the subject field in silk test

    [QUOTE]Originally posted by QAsuvarna:

    the error shown was "
    Window '[dialog box] test mail -Message (plain text)' was not found
    Occured in Dialog box("test mail -Message (plain Text").CustomWin("[AfxWnd]#1|$103.DialogBox("#1|$0").CustomWin("[Rich edit20A] test mail |$4101")::TypeKeys)"

    'test mail' above was probably the name of a message when you recorded the script.

    Replace 'test mail' with '*' in your script.

    Hope this helps


    ------------------
    John W Green
    jwgreen@automationexpertise.com
    http://www.automationexpertise.com

  6. #6
    Senior Member
    Join Date
    Jul 1999
    Location
    Burlingame CA 94010
    Posts
    502
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: unable to capture a mail with the subject field in silk test

    Glad I could help

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

vBulletin Optimisation provided by vB Optimise v2.6.0 Beta 4 (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging v3.0.9 (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Questions / Answers Form provided by vBAnswers (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
vBNominatevBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Feedback Buttons provided by Advanced Post Thanks / Like (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Username Changing provided by Username Change (Free) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
BetaSoft Inc.
Digital Point modules: Sphinx-based search
All times are GMT -8. The time now is 12:43 AM.

Copyright BetaSoft Inc.