SPONSORS:






User Tag List

Results 1 to 4 of 4
  1. #1
    Member
    Join Date
    May 2001
    Location
    Santa Clara, CA, USA
    Posts
    57
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    How to run a Shortcut Link

    I am trying to uninstall a software through Silk and for that I need to run the uninstaller link present in some dir like C:\All Users\Start Menu\Programs\MyApp\Uninstall.lnk
    Till now I was running the link by clicking START button --> Run --> <Full Path of link>

    But this method is not a fool proof method.
    I tried START and SYS_Execute they do not work. If I use START it throws error 193 and exits and if I uses SYS_EXECUTE. The agent dies with a Windows error ....

    If anyone could suggest a better idea I would appreciate ur help


  2. #2
    Member
    Join Date
    Jan 2002
    Location
    Nuremberg, Germany
    Posts
    77
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: How to run a Shortcut Link

    Try & have a look at the second post in forum 002635.html.

    Maybe this helps.

  3. #3
    Senior Member
    Join Date
    Jul 1999
    Location
    Burlingame CA 94010
    Posts
    502
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: How to run a Shortcut Link

    Here's some code that should help if you can execute the link from the run dialog. Replace "calc" with the name if your link.

    Examples of how to launch explorer and find are included as well.

    Hope this helps


    ------------------
    John W Green
    jwgreen@automationexpertise.com
    http://www.automationexpertise.com

  4. #4
    Member
    Join Date
    May 2001
    Location
    Santa Clara, CA, USA
    Posts
    57
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: How to run a Shortcut Link

    Thanks for the inputs. Actually I did as follows.
    After getting the lnk file, I created a Batch file on the run, copied the complete lnk name& path into it. And then called the batch file using SYS_EXECUTE.
    After I am done with the batch file I delete it.

    This works like a cute ...

    Thanks for all the help. Hope this helps someone

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

vBulletin Optimisation provided by vB Optimise v2.6.0 Beta 4 (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging v3.0.9 (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Questions / Answers Form provided by vBAnswers (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
vBNominatevBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Feedback Buttons provided by Advanced Post Thanks / Like (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Username Changing provided by Username Change (Free) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
BetaSoft Inc.
Digital Point modules: Sphinx-based search
All times are GMT -8. The time now is 02:21 PM.

Copyright BetaSoft Inc.