SPONSORS:






User Tag List

Results 1 to 7 of 7
  1. #1
    Junior Member
    Join Date
    Apr 2002
    Location
    Irvine, CA, USA
    Posts
    6
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Silk test not selecting Popup List

    Hello everyone,

    Great forum. I am new to Silk and this is my first (and definitely not my last) request for help. Please bear with me.

    My application has a lot of popup lists/pulldown. For some reason I get no response running my script that selects an element (like State or Mr/miss etc ).
    I get ' "CA" not found or ' "Mr." not found'

    What's weird is when I did a sample record/playback ( :-0 ) of the page/popup the application finds the element and selects it. Don't know why it doesn't select it when I run the script using the same commands.

    Any ideas ? Thanks much.



    ------------------

  2. #2
    Senior Member
    Join Date
    Nov 2001
    Posts
    375
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Silk test not selecting Popup List

    could u give the details of the declarations u have given for this popuplist in your frame file
    and the script u have for it....
    a lot of people might be able to help


    ------------------

  3. #3
    Junior Member
    Join Date
    Apr 2002
    Location
    Irvine, CA, USA
    Posts
    6
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Silk test not selecting Popup List

    **** Here's the declaration in my inc file:
    [-] window BrowserChild ClaimConnectSingleClaim2
    [ ] tag "ClaimConnect - Single Claim"
    [ ] parent Browser

    [-] HtmlPopupList Billing1
    [-] multitag "? Billing:"
    [ ] "#1"
    [-] HtmlPopupList Rendering1
    [-] multitag "? Rendering:"
    [ ] "#2"

    **** Here's part of the testcase:

    STRING sBilling = "Mr. Billing Test"
    STRING sRendering = "Mr. Rendering Test"


    ClaimConnectSingleClaim2.SetActive ()
    [ ] ClaimConnectSingleClaim2.Billing1.Select (sBilling)
    [ ] ClaimConnectSingleClaim2.Rendering1.Select (sRendering)

    Thank you for your speedy response.


    ------------------

  4. #4
    Junior Member
    Join Date
    Jun 2001
    Location
    hyderabad,India
    Posts
    13
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Silk test not selecting Popup List

    could u state the error more clearly...is it something like "control not responding"?

    otherwise check for the spaces in the string...



    ------------------

  5. #5
    Senior Member
    Join Date
    Aug 1999
    Location
    Cambridge, UK
    Posts
    470
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Silk test not selecting Popup List

    It's possible that the elements in the PopupList are padded with spaces; so where you are trying to select "Mr." and it doesn't find it, you would succeed if you searched for "Mr. " or something. Try using the method GetContents() to find out what the available elements are.

    ------------------

  6. #6
    Junior Member
    Join Date
    Apr 2002
    Location
    Irvine, CA, USA
    Posts
    6
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Silk test not selecting Popup List

    Thank you for all the tips.
    I see the problem now:

    Did Getcontents () and it was listing the previous fields contents even if by using windows identifer Silktest was identifying the fields I listed above (billing1 and rendering1).

    I am embarrassed to admit that I have to windows declarations for this page.

    So I think y'all will agree with just having just one declaration for the page.

    * Looking at why I had two it was because depending on the User login I use, this
    page will have a transmittal report object link.

    How do I handle this situation, when a page may or may not have this extra object ?

    Perhaps Silktest was getting confused on the location of the Billing/rendering fields when the "transmittal" object was there or not.

    More tips welcome.

    ------------------

  7. #7
    Junior Member
    Join Date
    Apr 2002
    Location
    Irvine, CA, USA
    Posts
    6
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Silk test not selecting Popup List

    It works !

    After trying all the suggested tips y'all gave me my script now works ! I will now apply the fix to the other scripts.

    I still have more than one windows declaration for the page. Are there legit situations that one can have more than one for a page - or is this a bad practice ?

    Have a good weekend you all made mine.

    ------------------

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

vBulletin Optimisation provided by vB Optimise v2.6.0 Beta 4 (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging v3.0.9 (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Questions / Answers Form provided by vBAnswers (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
vBNominatevBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Feedback Buttons provided by Advanced Post Thanks / Like (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Username Changing provided by Username Change (Free) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
BetaSoft Inc.
Digital Point modules: Sphinx-based search
All times are GMT -8. The time now is 02:02 PM.

Copyright BetaSoft Inc.