SPONSORS:






User Tag List

Results 1 to 5 of 5
  1. #1
    Junior Member
    Join Date
    Sep 2001
    Location
    India
    Posts
    7
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Mouse Delay in Agent causes problems

    I am testing a Java Web Application. I had written a few scripts for demo purpose. The scripts ran well before the demo. The scripts ran hay wire during the demo, the reason being - i delayed the Agent - Mouse Delay by 2 seconds. I changed the mouse delay settings to 1.5 and the scripts ran well.
    I want the mouse delay to be definately more than 2 seconds, any solutions?

    Thanks in advance.


    ------------------

  2. #2
    Senior Member
    Join Date
    Nov 2001
    Posts
    375
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Mouse Delay in Agent causes problems

    what exactly is the eror you get if u increase the mouse delay?
    elaborate a little bit.....


    ------------------

  3. #3
    Junior Member
    Join Date
    Sep 2001
    Location
    India
    Posts
    7
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Mouse Delay in Agent causes problems

    I am trying simulate a simple click on a combobox and select a specified item, the details of which are displayed in a text field given just below the cmb.
    Now if i increase the settings in the mouse delay, it does not select the item i have specified in the script and instead goes to the Browser Favourite menu item and selects Add to Favourites..
    The test case fails and the result file displays "
    [ ] Test Case begins
    [ ] 134
    [ ] *** Error: Control is not responding
    [ ] Occurred in Select

    I fail to understand why is the 'mouse delay' causing the problem, otherwise the script runs fine.



    ------------------

  4. #4
    Senior Member
    Join Date
    Nov 2001
    Posts
    375
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Mouse Delay in Agent causes problems

    Set the following option just before the line causing the error:
    Agent.SetOption(OPT_VERIFY_RESPONDING, FALSE)

    and

    Agent.SetOption(OPT_VERIFY_RESPONDING, TRUE) after it

    might work
    best of luck



    ------------------

  5. #5
    Junior Member
    Join Date
    Sep 2001
    Location
    India
    Posts
    7
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Mouse Delay in Agent causes problems

    I tried the above method, but it still does not seem to work.
    To be in between the valley and cliff, i have tried to set the mouse delay to 1.9 and it works fine. So far so good.
    Thanks Atish.

    ------------------

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

vBulletin Optimisation provided by vB Optimise v2.6.0 Beta 4 (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging v3.0.9 (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Questions / Answers Form provided by vBAnswers (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
vBNominatevBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Feedback Buttons provided by Advanced Post Thanks / Like (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Username Changing provided by Username Change (Free) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
BetaSoft Inc.
Digital Point modules: Sphinx-based search
All times are GMT -8. The time now is 07:37 AM.

Copyright BetaSoft Inc.