SPONSORS:






User Tag List

Results 1 to 9 of 9
  1. #1
    Junior Member
    Join Date
    Jan 2002
    Posts
    12
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Silk doesn\'t recognize IE6

    Firstly, I'm sorry because my english is not very good.

    I'm using Windows 98 french and Internet Explorer 6 (Virtual Object) french too. I've installed Silk 5.5 SP2 (964n) and my problem is:

    When I start my script, Silk verify if my browser is Explorer or Netscape, it detect Explorer and open it.

    After, in explorer.inc (line 366) Silk verify if the browser exist. Silk doesn't detect the browser. It return an error (unable to start Internet Explorer 6) and...it open a new Explorer window????

    I'm using IE6 english version on Windows 2000 with the same version of Silk and all works fine.

    Does anyone have an idea?



    ------------------

  2. #2
    KS
    KS is offline
    Senior Member
    Join Date
    May 2001
    Posts
    265
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Silk doesn\'t recognize IE6

    I think you need to add a french tag in your explorer.inc it needs to go where tags are for IE 6

    ------------------

  3. #3
    Junior Member
    Join Date
    Mar 2003
    Location
    San Francisco, CA, USA
    Posts
    23
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Silk doesn\'t recognize IE6

    I've run into the same problem with Silktest 6.5, I'm on an english system though. I can't get past the enable extensions step. Here is step by step what I am doing(a routine I've done many times on many other os's)

    1. Open Silktest
    2. Create a new project
    3. Open IE 6.0
    4. Click the Enable Extensions button in Silktest
    5. select IE 6.0 (in my case it's the only other application running)
    6. click next
    7. The dialog asks me to restart my application, so I shut down IE and restart

    Then nothing... The dialog never recognizes that I've re-started IE 6.0

  4. #4
    Super Member
    Join Date
    Jul 2003
    Location
    Boulder, CO
    Posts
    1,276
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Silk doesn\'t recognize IE6

    You'll have to post all the details of what you've done in the Runtime options for extensions AND in the extension enabler for someone to be able to guess what is going wrong. Also specify if you are testing locally or using a remote machine.

    This sounds like extension enabling troubles, of which there are many types.

    Vous pouvez ecrire en francias si ca aide pour expliquer le probleme...
    Chris R Mead

    The opinions expressed herein are my own personal opinions and do not represent my employer's view in any way.

  5. #5
    Junior Member
    Join Date
    Mar 2003
    Location
    San Francisco, CA, USA
    Posts
    23
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Silk doesn\'t recognize IE6

    I don't change the options at all... I don't even get that far... here is the options file:

    [ProjectState]
    ProjectWndInfo=214,0,1,1
    CurrentProject=D:\flashfarm\depot\main\player\QA-Automation\silk\test-ie\test-ie.vtp

    [Classmap]
    AOL Toolbar=Ignore
    _AOL_Toolbar=Ignore

    [Extension: IEExec.exe]

    [Extension: waol.exe]

    [Extension: connect.exe]

    [Extension: iexplore.exe#4]

    [Extension: iexplore.exe#5]

    [Extension: iexplore.exe#6]
    domex.dll=TRUE

    [Extension: java.exe jre.exe jrew.exe appletviewer.exe javaw.exe]

    [Extension: pr3240.dll]

    [Extension: netscp6.exe]

    [Extension: netscp.exe]

    [Runtime]
    UseFiles=extend\explorer.inc
    DefaultBrowser=explorer6_DOM

    [General]
    HelpFiles=4test.txt, extend\browser.ht, extend\domex.ht

    [State]
    OptionsSet=d:\flashfarm\depot\main\player\qa-automation\silk\test-ie\test.opt
    CurrentDirectory=D:\flashfarm\depot\main\player\QA-Automation\silk\SA-win98
    LastOptionSet9=
    LastFile9=
    LastOptionSet8=
    LastFile8=
    LastOptionSet7=
    LastFile7=
    LastOptionSet6=
    LastFile6=
    LastOptionSet5=
    LastFile5=
    LastOptionSet4=
    LastFile4=
    LastOptionSet3=
    LastFile3=
    LastOptionSet2=
    LastFile2=
    LastOptionSet1=
    LastFile1=
    Placement=266,119,864,609,3

    [FileList]

  6. #6
    Super Member
    Join Date
    Jul 2003
    Location
    Boulder, CO
    Posts
    1,276
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Silk doesn\'t recognize IE6

    It looks like you have the GUI configured for IE 6 only. In your first post you also mentioned using Netscape. You should probably focus on just working with IE 6 for a while and not try Netscape until you are having more luck. Then be aware that IE and Netscape tests cannot share 100% of the same scripts and declarations.

    Have you looked in your explorer.inc file to see if the tag and multitag statements have strings which correspond to the French IE Captions, Menus, etc? I haven't seen a French Win98 or IE 6 in a long time and I can't remember what it looks like but it seems like "Microsoft Internet Explorer" might be replaced with something else (in French) and "Close" might also be something else (Fermer?).

    I don't have a line like this in my opt file:
    CurrentProject=D:\flashfarm\depot\main\player\QA-Automation\silk\test-ie\test-ie.vtp
    <font size="2" face="Verdana, Arial, Helvetica">Since you aren't using Segue's default project directory you may need to copy the extend subdirectory over into to your project directory. I had to do something like this for my non-default location since this line is a relative directory:
    UseFiles=extend\explorer.inc
    <font size="2" face="Verdana, Arial, Helvetica">Last, run the Extension Enabler utility program and be sure that only the checkboxes for IE 6 are checked and that only the leftmost checkbox is checked (don't check activeX and fault trap).
    Chris R Mead

    The opinions expressed herein are my own personal opinions and do not represent my employer's view in any way.

  7. #7
    Junior Member
    Join Date
    Dec 2002
    Posts
    2
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Silk doesn\'t recognize IE6

    1. I was installed with IE5.5 version in my system.
    2. Now i installed silktest 7.0 and while installed i was selected IE 5.5 as default browser.
    3. After installing silktest, i was upgraded to IE 6.0 version.
    4. Now i opened silktest and created project and then added test plan, enabled extensions, set the recovery system, and then added script file and executed successfully.
    5. Now every work saved with the proper details.
    6. Now i closed and opened the same project and tried to execute the scripts.
    7. Now i am facing problem like, silktest invoking the browser but not inserting the URL. After 60 secs of elapsed time it is giving error like (*** Error: Unable to start the Internet explorer 6.0 DOM version).

  8. #8
    Junior Member
    Join Date
    Mar 2003
    Location
    San Francisco, CA, USA
    Posts
    23
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Silk doesn\'t recognize IE6

    I'm sorry... I new I should have started a new thread but this case looked so similar... I didn't start this thread, and I'm not using a french version of win98, I'm using an english version...

    I'm not trying to do anything fancy here, just simple use IE in any way shape or form... saradhi seems to have found the same problem that I did(I get the error 'Unable to start Internet explorer 6.0' as well... which is strange because silktest does actually open IE, and it's sitting there, open.

  9. #9
    Super Member
    Join Date
    Jul 2003
    Location
    Boulder, CO
    Posts
    1,276
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Silk doesn\'t recognize IE6

    Personally, I do not set a default browser. I leave it set to (none) and then call SetDefaultBrowserType() and then SetDefaultBrowser() according to which browser I am testing with.

    It is important not to check any exta stuff in the Extension enabler. Just get the first (leftmost) checkbox for the browsers necessary and no extras. The exact same goes for Options &gt; Extensions.

    It is also important to be sure that you have a reference to explorer.inc and netscape.inc in the Runtime Options, Use Files box. Make sure that this relative path makes sense. If you are working in C:\test and you don't have a /extend subfolder in there, you'll have problems. SilkTest assumes that you want to use its project directory structure.

    I think that silktest can open IE 6.0 thinking that it is IE5.0, IE5.5, whatever as long as the exe is in the same place with the same name. Once the program is up and running, though, the IE5 extensions won't work for IE 6.0.
    Chris R Mead

    The opinions expressed herein are my own personal opinions and do not represent my employer's view in any way.

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

vBulletin Optimisation provided by vB Optimise v2.6.0 Beta 4 (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging v3.0.9 (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Questions / Answers Form provided by vBAnswers (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
vBNominatevBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Feedback Buttons provided by Advanced Post Thanks / Like (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Username Changing provided by Username Change (Free) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
BetaSoft Inc.
Digital Point modules: Sphinx-based search
All times are GMT -8. The time now is 10:43 AM.

Copyright BetaSoft Inc.