SPONSORS:






User Tag List

Results 1 to 3 of 3
  1. #1
    Junior Member
    Join Date
    Jan 2002
    Posts
    1
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Need help with Client/Server testing

    Hello,

    I'm trying to learn the client/server side of SilkTest scripting. I want to run code in parallel on 2 machines (A and B). He's what I have:
    [-] multitestcase MyTest (LIST of STRING lsMachines)
    [ ] STRING sMachine
    [ ]
    [ ] // Connect to all machines in parallel:
    [-] for each sMachine in lsMachines
    [-] spawn
    [ ] SetUpMachine (sMachine, w)
    [ ] rendezvous
    [ ]
    [ ] // Run testcases in parallel:
    [-] for each sMach in lsMachines
    [-] spawn
    [ ] SetMachine (sMachine)
    [ ] Browser.LoadPage("http://www.cnn.com")
    [ ] // Call testcase(s) or call main()
    [ ]
    [ ] rendezvous


    Silk connects to all machines but loads the cnn page only on machine B, skipping A. I cannot understand why. I tried to use parallel instead of spawn and Silk gives me "No default machine is set" message. Does anybody know where to find more information about this topic? Silk tutorial does not have much.

    ------------------

  2. #2
    Super Member
    Join Date
    Jul 2001
    Location
    Earth
    Posts
    1,882
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Need help with Client/Server testing

    Indentation levels are important here and this site makes it difficult to see. Can you post the script as an attachment to this?

    ------------------
    James Soderborg
    http://www.ameliortech.com
    jamesso@ameliortech.com

  3. #3
    Senior Member
    Join Date
    Aug 1999
    Location
    Cambridge, UK
    Posts
    470
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Need help with Client/Server testing

    Or put the pasted code between CODE and \CODE tags. I left off the square brackets there so that you could see what I was talking about, but in order for the flags to work you'll need to put each of them in square brackets.
    See the link for UBB code for a full explanation.

    ------------------

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

vBulletin Optimisation provided by vB Optimise v2.6.0 Beta 4 (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging v3.0.9 (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Questions / Answers Form provided by vBAnswers (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
vBNominatevBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Feedback Buttons provided by Advanced Post Thanks / Like (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Username Changing provided by Username Change (Free) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
BetaSoft Inc.
Digital Point modules: Sphinx-based search
All times are GMT -8. The time now is 10:42 AM.

Copyright BetaSoft Inc.