SPONSORS:






User Tag List

Results 1 to 4 of 4
  1. #1
    Junior Member
    Join Date
    Aug 1999
    Location
    Boston, MA
    Posts
    16
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    web pages & errant tooltips

    Hi,

    I recently ran into trouble with silk thinking buttons were not exposed. Basically, the test clicks on a button which adds a new row to an html table. When the page is redrawn, the mouse is hovering over a button which caused IE to display a tooltip with the name of the button. The tooltip only stays up for a second or two, but that seems long enough for silk to think it is not exposed.

    I tried disabling 'verify windows are enabled', but that caused more problems.

    Adding the following little tidbit of code made the problem go away ...

    Now, the real question I have to answer ... what changed? I did not encounter this problem during the last round of app testing. The page didn't change in the latest version, I didn't upgrade silk, or the browser. Makes me wonder ...

    ------------------
    John McGrail
    John McGrail

  2. #2
    Senior Member
    Join Date
    Jul 1999
    Location
    New York, NY, USA
    Posts
    137
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: web pages & errant tooltips

    I think it is an agent timing issue. Basicly you need to play with the window retry times and ready timeouts. I find problems like this every so often when switching testing servers or if the network response times change. Sorry I can't help more than that because every time I do a new application I ssem to have to tweak the timing. Maybe some else around here has a better idea?

  3. #3
    Junior Member
    Join Date
    Aug 1999
    Location
    Boston, MA
    Posts
    16
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: web pages & errant tooltips

    hrrmmm ... my window timeout is 120 and my window retry interval is 0.06 ... I don't see how changing them will affect anything as it seems like Silk is recognizing immediately that the widget is available, and then also immediately recognizing it is not exposed.

    When I get time, I'm going to log a bug with segue tech support to see if they'll add an option to allow enabled, exposed, etc to also use the window timeout variable. Or, add a new timeout variable for exposed.
    John McGrail

  4. #4
    Member
    Join Date
    Oct 1999
    Location
    Austin, TX, USA
    Posts
    32
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: web pages & errant tooltips

    The MoveMouse method is what I've always used in the past. I'd also be interested in new ways for the workaround on tooltips.

    -cynthia

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

vBulletin Optimisation provided by vB Optimise v2.6.0 Beta 4 (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging v3.0.9 (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Questions / Answers Form provided by vBAnswers (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
vBNominatevBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Feedback Buttons provided by Advanced Post Thanks / Like (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Username Changing provided by Username Change (Free) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
BetaSoft Inc.
Digital Point modules: Sphinx-based search
All times are GMT -8. The time now is 04:14 PM.

Copyright BetaSoft Inc.