SPONSORS:






User Tag List

Results 1 to 4 of 4
  1. #1
    Junior Member
    Join Date
    Sep 2001
    Location
    Shrewsbury, MA, USA
    Posts
    19
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    sys_execute() and application output problems

    We're using silkTest to test the Microsoft Windows 2K Resource Kit tool "makecab" against one of our machines. This tool makes *.cab files.

    The problem we run into is that when the program runs it gives a status indicator in a continually updating percentage (ie. the program write the percent complete to the same line every interval). This creates some problem with silkTest, because i believe that it cannot handle that type of output.

    There is no way to use a command line argument to turn this "feature" off.

    When Sys_Execute() calls the program, it never returns as failure or success. The command just never returns. We fear that the command output overwrites the buffer in silkTest.

    Any info would be of help.

    ------------------

  2. #2
    Guest

    Re: sys_execute() and application output problems

    Sometimes Sys_Execute()is a pain.

    I have found that it is often easier to bring up a DOS Command prompt and TypeKeys() my commands there.

    This has some complications too:
    - reading results back from the command prompt
    - adapting to the changing window caption of the command prompt window
    - compatibility with the various windows versions.

    All of these problems have solutions.
    Search the forum for details.

    ------------------

  3. #3
    Junior Member
    Join Date
    Sep 2001
    Location
    Shrewsbury, MA, USA
    Posts
    19
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: sys_execute() and application output problems

    We're trying to use the type keys, but since its a command line, we use Sys_Execute to bring up a cmd.exe, but it runs in the background. There isn't anywhere to type those keys into.

    How do i invoke cmd.exe into the foreground?

    ------------------

  4. #4
    Guest

    Re: sys_execute() and application output problems

    See this previous thread:
    http://www.qaforums.com/Forum1/HTML/000962.html


    ------------------

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

vBulletin Optimisation provided by vB Optimise v2.6.0 Beta 4 (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging v3.0.9 (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Questions / Answers Form provided by vBAnswers (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
vBNominatevBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Feedback Buttons provided by Advanced Post Thanks / Like (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Username Changing provided by Username Change (Free) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
BetaSoft Inc.
Digital Point modules: Sphinx-based search
All times are GMT -8. The time now is 10:59 AM.

Copyright BetaSoft Inc.