SPONSORS:






User Tag List

Results 1 to 6 of 6
  1. #1
    KS
    KS is offline
    Senior Member
    Join Date
    May 2001
    Posts
    265
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    IE 5.5 MessageBox/Crash

    During automation I am consistantly encountering an IE error saying
    "Microsoft IE has encounter a problem and need to close. Sorry for inconvenience" it has two push button to push 'Send the error report' 'Don't Send'.
    Has anyone seen this issue. Automation just waits when it comes up and user has to manually click i.e.'Don't Send' button and IE shuts down and automation can continue. It is showing up even on IE6.0 all paltforms.
    Please help. (I tried handling the message box within silk but it doesn't get to that point)

    ------------------

  2. #2
    Senior Member
    Join Date
    Jun 1999
    Location
    Fremont, CA, USA
    Posts
    355
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: IE 5.5 MessageBox/Crash

    Yes, I have this same problem (search the forum here). I had it occur when a new window was launched, and then passed data back to the first window. When the new window was closed, the error occured.

    In my case, the first window was just a login page. So, using Browser.CloseOthers() to close that page solved my problem.


    ------------------
    David Genrich
    david@e2Open.com
    david_kim@usa.net

  3. #3
    KS
    KS is offline
    Senior Member
    Join Date
    May 2001
    Posts
    265
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: IE 5.5 MessageBox/Crash

    I have discovered that setting the Fault trapping opion ON solves all the IE crash problems. Whenever there is an access violation error or IE about to crash Silktest take control shuts down IE and move on to the next test case.

    ------------------

  4. #4
    Junior Member
    Join Date
    Nov 2001
    Location
    Boston, MA USA
    Posts
    13
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: IE 5.5 MessageBox/Crash

    I have same problem when trying to select item from popup list. Logged issue with Segue few weeks ago, but no answer yet. (Fault trapping not on.)

    ------------------

  5. #5
    Senior Member
    Join Date
    Jun 1999
    Location
    Fremont, CA, USA
    Posts
    355
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: IE 5.5 MessageBox/Crash

    I tried putting Fault Trapping on (for IE 5.5 DOM under win2k). Segue has a note saying to only turn Fault Trapping on as a last resort.

    Anyway, with fault Trapping on, IE 5.5 crashed even more frequently and SilkTest still didn't handle the IE Error Reporting dialog (Note: when this happens, IE locks up, so it also locks up the agent).

    So far, the best I have found that works for me is to close the login page that I have after the main browser window opens using the Browser.CloseOthers() method.



    ------------------
    David Genrich
    david@e2Open.com
    david_kim@usa.net

  6. #6
    Junior Member
    Join Date
    Dec 2001
    Location
    CA
    Posts
    21
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: IE 5.5 MessageBox/Crash

    I have also been getting the same problem
    on IE 5.5 sp2.

    I am running a test plan with testcases.And i get the error when one testcase ends
    and the next testcase starts.In the next test case i am reusing the existing browser window.

    I changed the script to close the browser window using Bowser.TypeKeys("<Alt-F4>")And open a new browser window for the next testcase.

    This works for me and does not give me the Internal agent error.So i guess this is some memory leak problem on IE .

    But Opening a new Browser window for each testcase makes the scripts unstable.I have seen
    that sometimes randomly while opening a new window ,favourites on the IE menubar gets clicked ,and the testcase aborts .
    This does not happen always .Any pointers
    why this is happenning

    But yes the best Solution for me that works is closing all the existing browser windows

    Cheers,
    Sandeep


    ------------------

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

vBulletin Optimisation provided by vB Optimise v2.6.0 Beta 4 (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging v3.0.9 (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Questions / Answers Form provided by vBAnswers (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
vBNominatevBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Feedback Buttons provided by Advanced Post Thanks / Like (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Username Changing provided by Username Change (Free) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
BetaSoft Inc.
Digital Point modules: Sphinx-based search
All times are GMT -8. The time now is 11:01 PM.

Copyright BetaSoft Inc.